Forum Discussion

arjanh's avatar
Icon for Nimbostratus rankNimbostratus
Nov 08, 2021

Route domain / partition problem

We're having an ltm cluster running and we have configured a number of route domains and partitions on it. All but one route domains have been separated from the Common partition and live in their own partition. The odd one seems to reside both in its own partition as well as in Common. As a number of virtual servers are active in this route domain (and are working fine), I'm reluctant to delete the partition and route domain, and start again from scratch.


I've tried editing the bigip.conf and bigip_base.conf files for both the Common and this partition, taking another partition as a template. However, when I issue "load sys config verify" I get the following error message:


01070973:3: The specified route domain (66) does not exist for address (<ip address>%66).

Unexpected Error: Loading configuration process failed.


The first item to be defined in bigip_base.conf is the route domain with this very id...


Any clues as to what's causing this?

2 Replies

  • If you're working on .conf files , make sure that you're editing the partition where the Routing Domain is configured.


    load sys config command parses all text configuration files in all partitions, so my main suspect will be that there might be an object configured in the wrong partition referencing a Routing Domain ID that it cannot see.


    If the RD is in a partition, remember that objects in /Common/ can't see it, so if you edited /Common/ partition bigip_base.conf file to insert a self-ip referencing RD 66 it will show a similar error.


    Check it like this:


    grep -i %66 /config/bigip*.conf


    Also, remember that Partition specific configuration files are in /config/partitions/<name>/bigip*.conf , again I would check those too.


    If you need to quickly un-do .conf file edits, you can just run a "tmsh save sys config" that will overwrite .conf files.


    Also, when wirking directly on .conf files, I'd recommend creating a .bkp copy before making any edit


    Hope this helps


  • arjanh's avatar
    Icon for Nimbostratus rankNimbostratus

    Hi CA,


    Thanks for the reply. We managed to separate another route domain along those lines. This particular one stubbornly refused to separate, and in the end we removed it from the config, and rebuilt it more or less from scratch. The rebuilding was initially done in the UI while checking the config files each time we added something. One thing that we noticed was that when creating a vlan in the new route-domain, in the UI it showed as being part of the route-domain, whereas in the config files, it showed as /Common/VLANxyz in /config/bigip_base.conf rather than in the bigip_base.conf in the route domain's directory. Removing the vlan from the Common route domain and adding it to the correct route domain in the config files, and then loading the changed config files from tmsh solved that issue. Once we had the vlans in the correct route domain, we encountered no more problems then typos :-)


    Thanks again,


    Arjan H