Forum Discussion

Scott_M_378955's avatar
Icon for Nimbostratus rankNimbostratus
Dec 13, 2018

Simple HTTP Load balancing setup not working

I'm working on a F5 Lab license, just trying to learn the basics of load balancing HTTP using the F5 web interface (I have not yet done anything with the CLI). I've setup two nodes, a pool that contains those two nodes, and a virtual server which uses the pool. I have an HTTP monitor on the pool, and it says that both nodes are working correctly on the F5 web interface. I also checked both web servers, and I can see the HTTP monitor connecting every few seconds (from the F5's management IP), so I know that the F5 monitor is in fact reaching out to those servers successfully.


On both web servers, I have set the default gateway on the only network adapter to the F5's management IP. Just for the heck of it, I tried setting the default gateway to the virtual server's IP, too, but I switched it back to the management IP.


I have tried with SNAT turned off and set to Auto Map, but I get the same results each time (site can't be reached). I've also tried playing around with the default persistence profile - set to none, or set to client-addr, and dest-addr. Same result each time - I cannot access the web servers through the load balancer.


So, anything solutions that I've seen posted for people with similar problems do not seem to be working for me. I'm sure it's probably one configuration somewhere that I'm missing. Any help to identify what the problem might be would be much appreciated. Remember, I'm a newbie to F5!






1 Reply

  • Sounds like you are trying to route traffic through the management interface which I am sure is prohibited.


    Ensure you have two VLANs setup with self IP addresses on different subnets and routing to the nodes is via a self IP and not the management interface.


    Then give it a test.