Forum Discussion

Stefan_Klotz's avatar
Icon for Cumulonimbus rankCumulonimbus
Mar 08, 2012

"Caching" of iRule commands



we found out some strange behavior, that sometimes iRule-commands are not directly active.


For example, we have some logging in place to verify something, but when we disable it again and checking the logs with "tail -f" we still see the log-entries from that iRule.


Might this be related to TCP-connection bundling from Akamai, which is in front of the BIG-IP? And the new iRule code will only match for new TCP-connection?


If that's the case, how can this behavior be broken/corrected? Because in case of troubleshooting or fine tuning for specific commands, the BIG-IP doesn't use the latest iRule changes.


fyi: we are already using a Oneconnect profile with a /32 mask.


Thank you!



Ciao Stefan :)


2 Replies

  • Hi Stefan,



    Changes to an iRule shouldn't take effect for existing connections. If you have a web proxy in front of your site (like Akamai) you'd need to wait for the connections to be closed or clear the connections. You could lower the "Maximum Requests" per TCP connection setting on the HTTP profile to force the proxy to open new connections sooner. By default it's set to 0 (unlimited). Once you see all new connections (or fewer instances of the old logging) you could reset the request limit to 0.



  • I guess you mean the "Maximum Requests" setting?


    Ok, then I will try this the next time.


    Thank you!



    Ciao Stefan :)