Technical Forum
Ask questions. Discover Answers.
Showing results for 
Search instead for 
Did you mean: 
Custom Alert Banner

BIG iQ discovery issues with error Unauthorized 401


I am experiencing discover issue while trying to add the F5 LTM guest to BIG IQ, Its throwing error as "check credentials: Unauthorized(401)" even though the credentials are correct.The guests are running code Big IQ is running


I have tried clearing reset java storage as well as restjavad process. Any suggestion would be greatly appreciated.





Have you confirmed that the request from the BIG-IQ is making it to the BIG-IP in question? Are you 100% certain that they are the correct credentials for the admin user of the BIG-IP? You should be able to perform a tcpdump on the BIG-IP on the interface that the BIG-IQ is connecting to so you can validate the request is making it to the BIG-IP. You should also be able to validate the user attempted to log into the BIG-IP by checking the audit logs.


Hi ashu,

You have to use "admin" - not "root" - credentials - either the admin user itself or a user with similar privileges.


Thanks all for the reply, I have tried to use admin/root as well as my Tacacs credentials and all of them throwing this error.  I dont see this issue with code

The connectivity from BIG IQ to the VCMP guest is good as i can telnet over port 443 as well as 22.

So, no issues with BIG-IP, but doesn't work?

If you still have any BIG-IP in the error conditions, give this article a go:


Yes thats correct, No issues with

I have already tried to clear rest java storage and restated the restjavad process as well, i know the upgrade to will fix the issue however was looking for some workaround solution.

This is crazy... can you try a reboot of the BIG-IP, just to take some weird cache issue out of the way?


Community Manager
Community Manager

Hi @ashu_aggarwal1 - were you able to resolve your issue with the help from @Mike757 and @Paulius, or are you still having problems?



Could you fix this?

I have tried suggested workaround but it still fails.

I have tried rebooting device and I have upgraded to (from and I am not able to add big-ip to the big-iq.

Any ideas?


@pponte If you are user @ashu_aggarwal1 as well you should really stay logged in as the same user in order to not confuse those who are assisting you. Aside from that, it seems that you are at the position where you need to perform a code upgrade to resolve the issue if not of the articles are resolving your issue. I recommend creating a QKVIEW and uploading it to iHealth if a code upgrade to the latest does not fix your issue. This is all assuming that you have logged into the BIG-IQ CLI and attempted to SSH to the management IP of the BIG-IP as well as performing a rest command to 443 on the management IP of the BIG-IP as well. The user credentials need to be the local admin credentials of the BIG-IP in question.