Forum Discussion

Jon_47375's avatar
Icon for Nimbostratus rankNimbostratus
Mar 01, 2012

HA Config Synch

I've noticed that when we make additions to virtual servers or add pools that the active server does not push this config to the standby when we synch the changes.



Is there a config option I'm missing to make the synch operation actually do something?







3 Replies

  • Hi Jon,



    Which version of LTM are you using? The shared config should be synched in v9-10. In v11 things have changed a bit.



  • Thanks for the reply, Aaron. We discovered the problem. We're running v9. I discovered the problem. We had some old iRules that had quotes in them but they were not escaped. The config's worked however they would not synch between the two even though it said it did from the web interface.



    I had to edit the bigip.conf on disk on the active, verify it and then load it to memory. I did the same thing to the standby unit though doing a synch from the web interface at that point would have worked.



    Really strange that the web interface is basically broken and doesn't tell you the real status of the synch process or whether or iRules are actually syntactically correct. Oh well. F5 support was awesome as always and got us working in short order.


  • Glad to hear you resolved this. There have been some bugs in iRule parsing which you ran into. The GUI should show the same error the CLI returns in current LTM versions.