Forum Discussion

Gary_Galehouse_'s avatar
Icon for Nimbostratus rankNimbostratus
Jun 16, 2016

Attempting to delete from a bundle fails with "Unknown Error" from iControl (SOAP)



I'm working with iControl (SOAP) version 12.0, build 1.0.628 and trying to delete a certificate from a bundle that I created using iControl. I always receive this error:


Exception caught in Management::urn:iControl:Management/KeyCertificate::certificate_delete_from_bundle() Exception: Common::OperationFailed primary_error_code : 16908390 (0x01020066) secondary_error_code : 0 error_string : Unknown error 16908390


I thought perhaps I wasn't building the X509 subject properly, so I went so far as to read the bundle contents, using get_certificate_bundle_v2, searching for the certificate to be removed, and using the subject object to pass into certificate_delete_from_bundle. I received the same error. I tried changing one of the subject fields to an invalid value, and received 'not found', and also changed the bundle name and received 'not found'. So it appears to be able to locate the bundle and certificate, but fails performing the removal.


Any insight as to why I might be receiving this error would be greatly appreciated. Also, let me know if you need any further information to help.