Technical Forum
Ask questions. Discover Answers.
cancel
Showing results for 
Search instead for 
Did you mean: 

winscp error

Anju
Altostratus
Altostratus

Folks,

 

I have been trying to access some files from the box since we upgraded the code on F5 (14.1.0.6), can someone help me understand if it has to do with some settings on F5? if so, how can I fix this? Getting the below error -

Received too large (1936094320 B) SFTP packet. Max supported packet size is 1024000 B. The error is typically caused by message printed from startup script (like .profile). This message may start with "sftp". Cannot initialize SFTP protocol. Is the host running a SFTP server?

 

Thank you!

0691T000005noiGQAQ.jpg

1 ACCEPTED SOLUTION

Kin
F5 Employee
F5 Employee

This is the article i was referring to

K16621651: Error Message: Received too large (1936094320 B) SFTP packet

https://support.f5.com/csp/article/K16621651

Refer to the recommended actions.

View solution in original post

8 REPLIES 8

Samir
Nacreous
Nacreous

Can you try to login LB device via root user and transfer the file because we face some challenges V13.x.

 

Below link may help you.

 

http://www.vmwarearena.com/winscp-connection-to-vcsa-failed-received-large-sftp-packe/

Thank you Samir, unfortunately, this option does not work for me.

Halil_İbrahim
Nimbostratus
Nimbostratus

If you have remote authentication option on F5 you must create local user (named with same as remote user) to connect via sftp.

 

Or follow this article;

 

https://support.f5.com/csp/article/K22885182

I followed the later article you mentioned for a time being now. Thank you so much. Need to explore the first option though. Do we need to have root privileges to create a local user account? Also, where can we check the rights given to us on the box?

 

If you dont want to solve this problem in winscp side, you should create local user on F5.

 

For example; you have AD user named Anju. You will create local user named Anju and give it "advanced shell" right. After that you will login with AD user&pass with "advanced shell" right. ( Only users which have Administrator or User Manager role can create local users)

 

To see what is your rights, simply when you login CLI you can not pass to shell with "run util bash" command, Only you will have tmsh access.

 

Don't forget that it is workaround solution. On newer software versions users which have not Advanced shell rights can not make sftp connection. And it is by design.

Kin
F5 Employee
F5 Employee

I remember there is an article for this. Meanwhile, you only encountered this recently, then it's due to the fix at

https://support.f5.com/csp/article/K38941195

You can grant your user Administrator role with Advanced shell access. System-> Users-> username

OR

For Administrator role w/o Advanced shell access, on wincp, use the SCP protocol + click Advanced

Environment, select SCP/Shell, for Shell, type bash

Ok then connect

Kin
F5 Employee
F5 Employee

This is the article i was referring to

K16621651: Error Message: Received too large (1936094320 B) SFTP packet

https://support.f5.com/csp/article/K16621651

Refer to the recommended actions.

Anju
Altostratus
Altostratus

Thank you!