cancel
Showing results for 
Search instead for 
Did you mean: 

Managing Local users on this device is not allowed. Please use the APM active device

Fab
Altostratus
Altostratus

I get this message in this menu: Access   ››   Authentication : Local User DB : Instances 

The "Create new instance" button is grey. I am on an active standalone device though...
APM version 15.1.6.1.

Any idea?

Fab_0-1663764261103.png

 

6 REPLIES 6

Kevin_Stewart
F5 Employee
F5 Employee

Do you by chance have a device-group defined for this standalone device?

tmsh list cm device-group

If so, delete this and test again.

 

 

No device group, no.

 

cm device-group device_trust_group {
    auto-sync enabled
    devices {
        bigip1 { }
    }
    network-failover disabled
}
cm device-group gtm {
    devices {
        bigip1 { }
    }
    network-failover disabled
}

Any chance it WAS part of an HA pair or sync-group, and then disconnected?

https://support.f5.com/csp/article/K59100837

 

No it has always been standalone. I managed to create a database with a TMSH command, but not a user 😕

So interestingly enough, after testing a few things I ended up the same error message. But I was able to clear it with a reboot.

FWIW, the CLI syntax for create a localdb user is this:

ldbutil --add --uname="bob" --password="pass" \
--instance="/Common/my_test_db" \
--user_groups="" \
--login_failures="0" \
--change_passwd="0" \
--locked_out="0" \
--first_name="" \
--last_name="" \
--email=""

I get the same error message after a reboot. And when I try to type the command I get this message:

 

Managing Local users on this device is not allowed. Please use the device

 

Fab_0-1663771174424.png