Technical Forum
Ask questions. Discover Answers.
cancel
Showing results for 
Search instead for 
Did you mean: 

Ansible - bigip_software_install on a vCMP ?

PACT_member
Nimbostratus
Nimbostratus

Hello,

 

With ansible, is it possible to use the module bigip_software_install on a vCMP ? I can use it on the chassis but I keep getting errors on the vCMP.

 

The error I keep getting :

 

The full traceback is: Traceback (most recent call last): File "/root/.ansible/tmp/ansible-tmp-1549985751.13-193354053183356/AnsiballZ_bigip_software_install.py", line 113, in _ansiballz_main() File "/root/.ansible/tmp/ansible-tmp-1549985751.13-193354053183356/AnsiballZ_bigip_software_install.py", line 105, in _ansiballz_main invoke_module(zipped_mod, temp_path, ANSIBALLZ_PARAMS) File "/root/.ansible/tmp/ansible-tmp-1549985751.13-193354053183356/AnsiballZ_bigip_software_install.py", line 48, in invoke_module imp.load_module('__main__', mod, module, MOD_DESC) File "/tmp/ansible_bigip_software_install_payload_7nxPug/__main__.py", line 507, in File "/tmp/ansible_bigip_software_install_payload_7nxPug/__main__.py", line 498, in main File "/tmp/ansible_bigip_software_install_payload_7nxPug/__main__.py", line 296, in exec_module File "/tmp/ansible_bigip_software_install_payload_7nxPug/__main__.py", line 314, in present File "/tmp/ansible_bigip_software_install_payload_7nxPug/__main__.py", line 335, in exists File "/tmp/ansible_bigip_software_install_payload_7nxPug/__main__.py", line 151, in version TypeError: 'NoneType' object has no attribute '__getitem__'

My equipment :

 

BIG-IP 7800 with two vCMP everything in version 12.1.3.0.0.378

I want to upgrade to 12.1.4-0.0.8.

 

If the module bigip_software_install doesn't work on a vCMP, i think i'll try the bigip_command to upgrade.

 

0 REPLIES 0