Forum Discussion

Reynaldo_76704's avatar
Icon for Nimbostratus rankNimbostratus
Mar 29, 2012

Using Cacti with V11.1 on LTM

Somebody could use cacti 8.7 to monitoring VS statistics on LTM with Version 11 ?, before than upgrade from v10 to 11, cacti was working very well..

6 Replies

  • Your post is rather brief but I believe you have the same problem as I do so I'll elaborate this a bit further.

    We've had cacti monitoring a couple of nodes on v10 without any problem. As of upgrade to v11 (only one pair at the moment) the traffic stats for VS and pools are not being graphed anymore. All other graphs are ok - all v10 nodes and so are all the rest for v11, except the VS/pools..I get the output by hand running snmpwalk, the only noticable difference from before is you now have a partition name (e.g. /Common/VSname) instead of just VSname, don't know if it should make the difference. It's being shown in cacti as ''Connection Rate - VSname'' though. I tried deleting one and recreating it but it's still just VSname and no /Common/.. prefix, you can see that only by running snmpwalk..

    In the Data Query Debug I get

    + Running data query [11].
    + Found type = '3' [SNMP Query].
    + Found data query XML file at '/admin1/cacti/v0.8.7i-PIA-3.1/resource/snmp_queries/f5_bigip_vs.xml'
    + XML file parsed ok.
    +  missing in XML file, 'Index Count Changed' emulated by counting oid_index entries
    + Executing SNMP walk for list of indexes @ '.' Index Count: 0
    + No SNMP data returned 

    But if I run the query by hand (even including the oid_index_parse regexp) I get everything ok:

     snmpwalk -v2c -c *** x.x.x.x . |  egrep "^.*\.3375\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.(.*)$"|wc
         65     260   11420 

    And funny as it seems, I also get the same values in Cacti by the data query description:

    3) F5 BIG-IP - VS Statistics (Verbose Query) Uptime Goes Backwards Success [260 Items, 65 Rows]

    I've tried playing with the spine parameters and timeouts without any luck. I've done a tcpdump to see what gets back and LTM does reply to the query I just can't see the difference (apart from /Common/ prefix).

    Also in cacti.log for only this host I get at Vs*Connections and Pool*Connections as a result value: U which I don't with the v10 hosts..

    So regarding it was working before and it's still working for v10 hosts it seems that v11 has something cacti doesn't like in SNMP. Could it be anything doing with the /Common/ prefix in the names?

    Any ideas on how to further debug this issue?
  • Hello Kpiti, i have exactly the same issue: "Executing SNMP walk for list of indexes @ '.' Index Count: 0


    + No SNMP data returned "



    i'm trying a lot of things in cacti, make modifications to the f5_bigip_vs.xml file but is the same thing... we cannot get snmp data, i thing the problem is with cacti, may be in snmp.php file.
  • You right! i thing the problem is with "/" character tha now appears in the name of Virtual Servers, in this new version the name of virtual server is in the way that you told me..
  • I've been digging further on this one. It seems the rrd file is actually being updated, but all the values are NaN or non existent. So the problem must be somewhere in the Data Queries part of the Cacti process.. I've searched around cacti forums and as I can't really understand why, it seems to work if you set SNMP version to 1 in cacti for that host.. At least you get the list in Verbose Query. You need to delete the old pools and VS graphs/data sources and create new ones with /Common/ or whatever partition you have..


    I'm getting U values (e.g. nothing is being graphed) though but it's still a step forward.. I'll post if/when i solve this one..
  • Ok, this got even weirder, but I got the workaround - can hardly call this a solution.. The way I had to do it is like this:


    1. change the SNMP version on v11 host to 1. This gets you the correct list of VS&pools. You delete the old pools&VS graphs and datasources and create the new /Common/whatever graphs


    2. at this point you have the blank graphs but the values aren't coming in. When you check by hand, you get no reply from LTM but if you check them with v2c, you get them so..


    3. change the SNMP version of the host back to 2 and the values will start coming in and the graphs will start showing as expected



    I presume you'll have to switch back to v1 when adding new VS/pools and then back to v2c for values but at least there is a way.


    I suspect there was some mockery with SNMP on the F5 devel when implementing v11. I thought it to be a cacti problem but the fact that you get no value when querying with v1 and you get it with v2c makes me think there is something wrong with v11 SNMP implementation.



    I'll contact support to see if they can confirm or reject it, if they'll want to work on this problem..
    • notscud's avatar
      Icon for Nimbostratus rankNimbostratus
      Has anyone figured this out? I am having the same problem on v11.5.2 Any query with forward slashes fails