Forum Discussion

richard_77048's avatar
Icon for Nimbostratus rankNimbostratus
Jun 06, 2011

syntax errors when creating data-group




I am trying to define a data-group in version 10.2.1 and I keep getting this error:


Syntax Error: the "create" command does not accept wildcard configuration identifiers




A typical element of this data-group looks like this: /path/




Through trial and error I have observed the following behavior:


Leading slashes get the error.


Trailing slashes don't cause the error.


Quoting leading slashes gets the error.


Escaping leading slashes gets the error.


Quoting AND escaping doesn't get the error but leaves me with this: \/path\/, not what I want.




I punted and left the TMSH and created a data-group from the bigpipe shell but this is an unsatisfying workaround. How do I create this data-group from the TMSH?






6 Replies

  • Hi Richard,



    Can you give an example of the command(s) you're trying that are erring out?



    Thanks, Aaron
  • Aaron,



    I have tried it a couple of ways.




    Starting from entering the TMSH.


    /ltm data-group


    create test-group type string


    modify test-group


    records add { /path/


    At this point when trying to TAB complete I get the error message and, naturally, can't complete the command.




    The other way I have tried is to create the data-group in the same manner and then editing it. Like this:


    /ltm data-group


    create test-group type string


    modify test-group





    Here I enter vi and type:


    modify data-group test-group {


    records add {


    /path/ { }






    Upon saving and exiting, I get the error and have to bail on my changes.






  • bug 223707 - modify data-group records add {"\mypage"} get errorcreate doesn't accept wildcar (Formerly CR 131350)



    it is fixed in v11.
  • Hi Nitass,



    Thanks for finding this. Having a URI in a datagroup is such a common scenario, I'm surprised PD didn't consider a 10.x hotfix for this. I guess you can use bigpipe for 10.x to get around the issue.



    Richard, if bigpipe isn't a valid workaround for you, I'd try opening a case with F5 Support and ask for an engineering hotfix for this bug.



  • Hi Aaron,



    Welcome and yes u r always correct. ;-) The workaround is to use bigpipe.



  • Thanks for the information.



    Bigpipe is a fine enough workaround. It's just this didn't seem to be an odd use-case and I have gotten to like TMSH; having to use bigpipe just didn't seem like the best solution considering how good TMSH is everywhere else. But if that is how it is done, then that's how I'll do it.



    Thanks again,