Forum Discussion

Brian_Gibson_30's avatar
Icon for Nimbostratus rankNimbostratus
Apr 03, 2019

relative addresses not allowed on SCP request

I have a set of lab load balancers running 14.1. Whenever I try to scp a file to or from that box I get an error saying "relative addresses not allowed" Any idea what this is all about? The same SCP works on our 13.X boxes.


8 Replies

  • Hello,

    I am having the problem using version on Viprion "vCMP Guest", when I try drag and drop via "winscp", I recived this same error "relative addresses not allowed".


    Workaround: To copy my files using winscp, I use right botton mouse > copy on file and rigth botton mouse  > paste on my "desktop".


    I hope that works with you too.

    • John's avatar
      Icon for Altostratus rankAltostratus

      Thank you for the copy/paste workaround, works perfectly!

  • I know this is old but to help others, here is my workaround.

    Rather than using: "scp file.ucs remoteserver:"

    use the full path to the file you are sending "scp /var/local/ucs/file.ucs remoteserver:"

    Do this even if current working path is in the same directory as the file.

  • Few questions:


    • Can you still SSH to the F5 via the IP address on 14.1?
    • Do you still have access to the Bash shell via SSH?
    • How are you authenticating, username/password or ssh key?
  • MarkB's avatar
    Icon for Nimbostratus rankNimbostratus

    I hit this on a 13.1 box. I expect you found a workaround, but since it's not mentioned here, I'll add mine (for anyone else who searches on this issue)

    You just need to add a path to the SCP command.

    So instead of 'scp afile bigip:' use 'scp afile bigip:~' (for your home directory)

  • This bug is still not fixed? I got the error as well since years, but the copy/paste workaround from jhonny is working! Thx! 🙂