Forum Discussion

dan0001_19285's avatar
Icon for Nimbostratus rankNimbostratus
Oct 31, 2011

Newbie Problem Getting Networks Configured Correctly




I have VMWare Workstation 8 and have installed and licensed the LTM VE Trial successfully by following the release note for v10.1.0 trial. I have also been using the DevCentral Tech Tip - Laptop Load Balancing For The Developer With BIGIP LTM VE as guidance for values for the various network configuration settings.



I am also new to BIGIP so my troubleshooting skills are fairly minimal at present. I have also not made any changes to the vmware virtual network configuration so that I can hopefully rule out any potential problems there as I think all this should work "out-of-the-box".



My issue is that I have completed the BIGIP network setup, created a pool with two other vm guests and created a virtual server containing the pool, but I cannot get a response from the pool members when pinging or browsing the virtual server IP address.






vmnet1 (host only):


vmnet8 (NAT):



Management IP (bridged network):


External Self IP (vmnet 1, host only):


Internal Self IP (vmnet 8, NAT):



IIS Guest 1 (win2003r2):


IIS Guest 2 (win2003r2):


Virtual Server IP:



All subnets are



Troubleshooting done so far:


When logged in to the BIGIP, I can ping both the external and internal self ip addresses and also the virtual server IP successfully. I cannot ping the pool members (.80.131, .80.133) - the ping returns a destination host unreachable from the .80.2 address.



I have noticed that the .80.2 address is also defined as the default gateway for vmnet8 (NAT) and do not know if this would be causing an issue (but it was chosen in the tech tip and I didn't want to make any changes in the vmware network config yet until I had ruled out all potential config errors on the BIGIP side first).



Still in BIGIP, I cannot get a ping response from either vmnet1 or vmnet8 (.132.1, .80.1).



In the guest vm's, they can ping each other fine, but not any of the BIGIP ip's (destination host unreachable from the vmnet ip's).



The host can ping the guest vm's fine, but not any of the BIGIP ip's (again, destination host unreachable from the vmnet ip's).




My networking knowledge is moderate, but not great by any means! It seems as if the BIGIP ip's are on a completely different network and need some routing, but I don't see how that could be as they are within the address range for each vmnet interface.



Can anyone help? Also, please let me know if I have failed to post anything of relevance - I have tried to add everything I can think of, but I am sure I have missed something obvious.









10 Replies

  • IMHO, you should change self-IP to or something else since VMware already occupied in VMnet8 and I'm quite sure that duplicate IP always cause problem somehow.



    If possible could you provide us 'bigip.conf', 'bigip_base.conf' & 'bigip_local.conf'. So we know more about your configuration. One more thing did you enable 'IPEnableRouter' or your host OS or not???
  • Just think again, 'IPEnableRouter' won't related to the problem here since it's a network problem in the same subnet and ping should work first.
  • Hi Parinya, I didn't change it initially as I thought maybe it was meant to be the gateway, but I can see where you are coming from about it being a duplicate ip. Unfortunately, I changed it to .80.3 (and rebooted) as you suggested but the behaviour remained the same.



    I just cannot understand why they are "unreachable" when they are on the same subnet!??
  • Let me recall from my memory.


    1. Create VLAN


    2. Assign NIC to VLAN (we have to choose here whether NIC will be tagged or untagged)


    3. Assign self-IP per VLAN



    After a few steps above self-IP shall be reachable from within the same subnet right away, I think.


    I'm not sure if we didn't assign NIC to VLAN, can we ping self-IP. IMHO, we should check if we did assign correct NIC to correct VLAN.


    That's all I can think of for now.
  • Yeah, those three steps are covered by the basic setup wizard and seem (!) to have completed successfully. I have my internal vlan on interface 1.1 and external on 1.2 and it all seems to be correctly setup in the management pages (albeit to my untrained eyes).
  • From what you said, your configuration should be ok, assume correct NIC assigned as untagged to correct VLAN. So problem is something else.



    hmmm... I'm ran out of idea... Really sorry...



    Let's see if someone could provide us better troubleshooting steps. But if you can, provide configuration files within this thread would be good idea.
  • Don't worry, good news! I have got to the bottom of the problem and finally fixed it!



    Thanks for persevering as you convinced me that nothing was majorly wrong and it had to be something small which is exactly what it was in the end.



    Basically, there is a CRITICAL TYPO in the trial edition release notes which instructs you to assign 1.1 to internal and 1.2 to external. The laptop tech tip has a screenshot showing exactly the opposite config which I only noticed when I decided to go through each step thoroughly and compare.



    Once I switched them over everything started working fine :)



    PS @devcentral guys - might be worth updating the release notes, cannot believe I am the only noob to encounter this .....
    • sydflyer_221362's avatar
      Icon for Nimbostratus rankNimbostratus
      You saved my day!!!!!! For whoever not able to run network on F5 LTM VE on vmware, BEWARE: external should be assigned to 1.1, and internal should be on 1.2 ...
  • Well... tell you the truth that I didn't read that release note, so I'm have no idea about that though. Anyway, that's great. So you can now start testing real things. :)
  • Hi Guys,


    I am facing a strange issues in VMware workstation 10, I am unable to ping the external and the internal IP interface. Please help.


    Thanks Chetan