Forum Discussion

mrodriguez's avatar
Icon for Nimbostratus rankNimbostratus
Mar 23, 2021

Configuration Utility blank

HI! sometimes the configuration utility does not show the configuration information I tried to restart tomcat and httpd services, but i does not work. Finally, i have to restart the F5 appliance and then all works well. I couldn't find the cause of it Can you help me? My appliance is:


Product    BIG-IP


 Build      0.0.10




5 Replies

  • Did the CLI work ? If it worked ten you needed to restart the tomcat and the httpd service before a full reboot as the GUI could have ben just stuck:


    1. Log in to the command line.
    2. Type the following command to restart the httpd daemon
    3. bigstart restart httpd
    4. Type the following command to restart the tomcat daemon:
    5. bigstart restart tomcat




    I have seen such also when the system is overutilized as the GUI is not critical it gets turned off, so that there is more CPU/Memory for the other processes or when someone uses a lot of REST-API scripts and there is no configured tmsh timeout (by default it is not configured and I don't know why F5 networks have not set default timeout) and the scripts don't close correctly the session. I suggest checking the /var/log/kern.log and to monitor you device CPU and memory and SWAP memory to see if they start increasing (memory leakage) .

  • Thanks. I restarted that services, but screen stands blank. In logs, i don't see anything interesting. I'm going to restart the appliance, and monitoring memory. Thank you

    • Nikoolayy1's avatar
      Icon for MVP rankMVP

      Check httpd and tomcat logs, there could be errors. Also use the linux top command to see if there is an issue with cpu, memory or swap. If you see the issue share what it is and maybe how you resolved it. Thanks in advance.

  • My guess you are running out of memory. See in the logs if you could find OOM error (OutOfMemory).

    If thats the case, I would go & increase the memory provisioned for tomcat.


    I have come across these situations in the past. The only solution was to provision extra mb for tomcat.

    Keep us posted.