Forum Discussion

Larry_Lamb_5349's avatar
Icon for Nimbostratus rankNimbostratus
Nov 19, 2010

Codeshare Version 9.x Session Limiting iRule

We needed to limit concurrent HTTP sessions across a virtual server and found the following in codeshare which suited the bill.



I was able to apply the rule and customize it to suit our needs, however, I'm unable to config sync the HA pair or even issue a b load from the active unit without it failing. I get a syntax error



BIGpipe:010a0040:3: Syntax error in /config/bigip.conf line xxxx



Where the line number is that of the iRule that was accepted by the GUI and even the F5 iRule editor. The Rule functions wonderfully after application, but not being able to config sync is a real issue. I've tried both the customized version and the original on different units. I've tried to sniff out any syntax errors without much success. While I've used the BigIPs for several years, my iRules coding experience is still pretty newbish. Any assistance would be much appreciated








1 Reply

  • Found my own solution after a lot to tedious research.





    This thread discusses the issue and I solved the script issue by changing the following line in the RULE_INIT section.





    array set ::sessionar {}





    array set ::sessionar ""