Forum Discussion

scheuri's avatar
Icon for Nimbostratus rankNimbostratus
May 19, 2021

BigIP VE (LTM) crashes when uploading iso's by SSH/SCP

Hi all


I have an odd problem.

There is a virtual machine (BigIP VE) with version 13.1.3.x with enough ressources (RAM, CPU, disk) which crashes when I try to upload an ISO for upgrading using SCP/SSH (not the WebGUI!).

When I start the upload it takes a moment (it ranges from 10 to 35% progress) the VE crashes either completly or starts to act strangely (not login possible anymore, but the traffic is still running).

I have to power off the VM and then power it on again to actually remedy the issue.


We will have an extensive testing with the ESX team and checking the VE itself, but preliminary checks don't show any issues with storage (ESX wise or internally VE, there is enough space) or ressources (like CPU, RAM, etc.).


There is a second VM with the same statistics and same version, just another location and another ESX farm, but that one doesn't have an issue.


Beside the fact we certainly need to check more in depth with ESX, anyone an idea what I could check on the F5 side what might cause this?


Thanks a lot

2 Replies

  • Hello AlexBCT


    Thanks a lot for your reply.

    • No, I haven't tried to limit the speed. Its certainly worth a try and might give me a hint where to look for the root cause
    • The partitions have been checked and I have enough space left for the ISO (many times over actually). So I think that shouldnt be the problem unless F5 is not showing the correct sizes of the partitions on CLI
    • Yes, I have taken a qkview. However, as I don't exactly know what I am looking for I am not entirely sure I am missing something. Nothing was obviously faulty or an issue.
    • I am uploading via Management-IP. Unfortunately trying to use the selfip will not be easy as I have no real access to that network (and a file on a server that would make me able to reproduce the issue). Thanks though, it might be worth a try once I can actually test it.
  • Hi scheuri,


    That's an interesting problem indeed!

    Here are a few tips that are hopefully helpful in getting to the bottom of it;


    • Have you tried limiting the speed of the upload? (In WinSCP, you can do this under Transfer Settings, but most other tools should have it too) And then check if it still happens. Not that it SHOULD make a difference, but may give an indication of what may be causing it.
    • Have you checked the size of the partitions on your system as well? (in linux CLI: "df -lh" - ensure that the /shared partition has enough space left?
    • Have you taken a qkview file of the box and checked iHealth for any indications?
    • Are you uploading via a SelfIP or via the Management IP? Can you check (if allowed), if the other option works better? Again, SHOULD not make any difference, but may give an indication.