Forum Discussion

DineshVM_265886's avatar
Icon for Altostratus rankAltostratus
Jun 21, 2017

BigIP LTM Standby device is showing offline on the active device

We are using the BigIP LTM in HA with Active/Standby mode. Eventhough the configuration is in sync between them, the active device is showing the standby device as offline. And also the traffic group in stuck on the initializing/not Synced state for the NEXT ACTIVE DEVICE. I have tried rebooting both of the device, upgrading both the device with the latest hot fix and image(12.1.2 HF1). They are 4000 series BIG IP. Pleas let me know how do make the stand device from offline state standby state.


6 Replies

  • I had a similar issue while trying to add the Standby to HA the F5 KB steps recommend putting Standby in a "Forced Offline" state while preparing sync. Check the HA heartbeat Self-IP settings and be sure the port lockdown mode is "allowed default" The default setting is "allow none" which blocks the heartbeat but CMI is the exception to "allow none" so sync works.


    Doubt this is your problem but this came up in my search when I had the issue and may help others.


    • vigyu's avatar
      Icon for Altocumulus rankAltocumulus


      allow-none -> allow-default settings helped me


  • Hi,

    If possible post output of watch_devicegroup_device command (use CLI for that) from both devices, if you do not have Advanced Shell access but at least tmsh Terminal Access try run cm watch-devicegroup-device.

    Both commands should be performed separately on Active and Standby device.

    When posting use Preformatted Code button to format output.


  • I worked with F5 support and they took three days to troubleshoot the issue. Finally we ended up re creating the HA and that is when we found out the interfaces used for the HA is having a problem. When we used the management IP for failover, everything worked good. But when we use the HA interface IP, the standby device was showing offline. Not sure if the cable that is used to connect the HA ports is the problem. Support was unable o determine that. Thanks Piotr for all the different solutions you gave.


  • Hi,


    Well, my ideas did not help a lot, glad that you finally resolved this issue.




  • I had the same issue when upgrading an HA pair from 11.5.1 to 12.1. After upgrading the standby was seen as offline.


    I was on the phone for 4 hours. The device group was rebuilt, and still nothing.


    What fixed it was support adding the devices management interface to the network failover interface list.


    system-high avalibility-device connectivity-network failover


    I still don't understand why, and the explanation made no sense, but it was now 6am and it was working...


    The simple fact was I upgraded from 11.5.1 to 12.1 on a EXTREMELY stable HA pair that had a directly connected dedicated connection between the two units on interface 1.8 for the HA failover heartbeat in addition to the serial HA cable, and the HA pairing broke.


    And the solution was to rebuild the trust group, and add the management interface...and there was the left over original trust group visable in the GUI that I never got an explination why it is still there, but again it was 6am...but interesting that group has a value of hidden in it.


    So from my experience...if you are going to upgrade from to 12.x, add you management ips to the network failover ip list before you upgrade in addition to whether you use the hardware cable, or a dedicated ethernet cross connect...


    cm device-group /Common/device_trust_group { auto-sync enabled devices { /Common/ { } /Common/ { } } hidden true network-failover disabled }