cancel
Showing results for 
Search instead for 
Did you mean: 
Login & Join the DevCentral Connects Group to watch the Recorded LiveStream (May 12) on Basic iControl Security - show notes included.

unable to ping Webservers OVA from F5 LTM

SURAJ2
Nimbostratus
Nimbostratus

I am following Keith Barker video of F5 and implement the LAB setup in fro practicing and i am unable to ping the webservers (Red-11-WEB 10.2.0.11 , Green -10.2.0.22 and Blue 10.3.0.33) from F5. F5 having self IP (10.2.0.145 - internal) . also added these servers and internal in Vmnet-2.

In F5 the route for these destination servers resource is Vlan/turnel Internal but still unable to ping these web servers from F5.

16 REPLIES 16

Are you able to ping F5 self /MGMT IP from webservers?

 

Mayur

SURAJ2
Nimbostratus
Nimbostratus

No. F5 self / MGMT IP also not pinging from webservers,

Please again cross check if all servers and F5 interfaces are mapped to same nic/vmnet?

This causes problems most of the times. Also check gateways set.

 

Mayur

i checked all the servers and F5 interfaces are mapped to same vmnet2.

 

how can i check gateway in webservers?

 

In F5 , internal vlan an external vlan are there.

 

Do you have proper routes for above subnets on F5?

SURAJ2
Nimbostratus
Nimbostratus

the below routes are there in F5

 

SURAJ2
Nimbostratus
Nimbostratus

.

Prince
Altostratus
Altostratus

Hi Suraj,

 

Try below :

On the server CLI:

route add default gw INETERNAL-SELF-IP

 

To check routing:

route -n

 

Try to ping in either direction.

 

I have below setup and it just works fine:

Internal vlan on f5 mapped to interface 1.3

External vlan on F5 mapped to interface 1.1

 

Server nic in vmnet3

 

route add default gw 10.2.0.145 is not accepting in server getting below error.

operation not permitted

 

You need to login with root to do that..

 

with Root login i have added the route. but still unable to ping the node ip from F5 and vice -versa.

Prince
Altostratus
Altostratus

Try changing the vlan settings of internal to 1.3 and make server vnic as vnet3

done but same issue.

Hello Suraj,

 

You can do one thing. Download image for windows and build one VM under your lab and then try if you are able to ping F5 interfaces from it. If vnic mapping is correct, then F5 interfaces should be reachable from host.

 

Mayur

consul_2019
Cirrus
Cirrus

This is going to seem annoying to you as I know you say you have checked this on F5 VM...

 

But you need to double check that the MAC address of your VMNET network in VMWARE matches the MAC associated to your VLAN. And verify the same for the back-end server VM. Most of the time this IS the only issue. I've never had to play around too much after that to get things working.

 

If the back-end server and F5 self-ip are in same VLAN then no need to mess with routing configs on back-end. Obvs, you need a default route on F5, but the rest mentioned here, is not really required.

Also good to check that you didn't run into this bug:

 

https://support.f5.com/csp/article/K74921042