cancel
Showing results for 
Search instead for 
Did you mean: 

"re-starting big3d" over and over...

Fallout1984
Cirrocumulus
Cirrocumulus

I have a lab virtual F5 running v14.1.4 and noticed a "re-starting big3d" message over and over when logged in via SSH.

 

Broadcast message from systemd-journald@F5Lab01.mystuff.net (Tue 2021-08-31 13:52                             :30 CDT):

logger[28346]: Re-starting big3d

2021 Aug 31 13:52:30 F5Lab01.mystuff.net logger[28346]: Re-starting big3d

 

So far I've tried manually restarting big3d and httpd, then stopping/starting big3d and httpd, even rebooting the F5 and big3d is still re-starting. I also ran a load sys config verify in case anything odd appeared there, but it looked fine.

 

Has anyone seen this before? If so, how did you resolve it?

 

Thanks!

 

1 ACCEPTED SOLUTION

Hello Fallout.

 

It's difficult to diagnose this behavior without context, but big3d is related with DNS and iQuery communication.

REF - https://support.f5.com/csp/article/K13703

 

First, check if you have the DNS module enabled and if there is an iQuery tunnel established with another peer that could be failing (maybe certs or something else).

If the issue persists, you could try to reinstall the big3d daemon from another device.

big3d_install -use_ssh <target IP>

REF - https://support.f5.com/csp/article/K13312

 

Regards,

Dario.

Regards,
Dario.

View solution in original post

2 REPLIES 2

Hello Fallout.

 

It's difficult to diagnose this behavior without context, but big3d is related with DNS and iQuery communication.

REF - https://support.f5.com/csp/article/K13703

 

First, check if you have the DNS module enabled and if there is an iQuery tunnel established with another peer that could be failing (maybe certs or something else).

If the issue persists, you could try to reinstall the big3d daemon from another device.

big3d_install -use_ssh <target IP>

REF - https://support.f5.com/csp/article/K13312

 

Regards,

Dario.

Regards,
Dario.

Fallout1984
Cirrocumulus
Cirrocumulus

Dario,

 

Thanks for the info! I was able to resolve it using the info from https://support.f5.com/csp/article/K13703

that you provided.

 

When I initially displayed big3d, this is what I saw...

 

[root@F5Lab01:Active:Standalone] config # ls -al /shared/bin/big3d /usr/sbin/big3d

-rwxr-xr-x. 1 root root 5177018 Sep 17 2018 /shared/bin/big3d

-rwxr-xr-x. 1 root root 5868113 Feb 11 2021 /usr/sbin/big3d

 

So I used this procedure from the article to delete it...

 

Log in to the BIG-IP command line.

Note: In this example, on the software slot running 11.5.3.

 

Stop the big3d daemon by typing the following command:

tmsh stop /sys service big3d

 

Remove the copy of big3d in /shared/bin directory by typing the following command:

rm /shared/bin/big3d

 

Note: The BIG-IP system will automatically copy the 11.5.3 version of big3d from /usr/sbin/big3d to /shared/bin directory.

 

Start the big3d daemon, type the following command:

tmsh start /sys service big3d

 

...and after that it showed this:

 

[root@F5Lab01:Active:Standalone] config # ls -al /shared/bin/big3d /usr/sbin/big3d

-rwxr-xr-x. 1 root root 5868113 Feb 11 2021 /shared/bin/big3d

-rwxr-xr-x. 1 root root 5868113 Feb 11 2021 /usr/sbin/big3d

 

The big3d restart messages have not returned.

 

Thanks for your help!

Alan