cancel
Showing results forย 
Search instead forย 
Did you mean:ย 

My Virtual IP doesn't work?

Ren_Alcala
Cirrus
Cirrus

I have created my node/pool and Virtual Server on my F5 but it doesn't get the web app form my node server to view on the client side by navigating my VS IP as shown on my screenshot below. Did i miss something during configuration?? Also why my node status is in "Unknown" state? Hope someone can help me with the issue ๐Ÿ™‚ , THanks

 

 

0691T00000Co2wgQAB.png

 

0691T00000Co2wjQAB.png

Thanks

Renato

1 ACCEPTED SOLUTION

Hi  Node is showing unknown because you haven't configured any node specific health monitor while configuring the node. Now your virtual server is showing available it means the backend pool is available and the pool member is listening as well as reachable on the required web-service port. So with this configuration, you should be good.

 

Now coming to the issue that web app not accessible from client system, i would recommend you to check the traffic hits on the virtual server as well as pool under statistics. This will clarify that the request is reaching the F5 virtual server and hitting the correct pool members.

 

If traffic is reaching properly, then check the SNAT (Source Address Translation) settings on the virtual server. If backend web-server don't have F5 as its default gateway, you need to enable SNAT (Source Address Translation) settings on the virtual server and you can set it to Auto-map. Basically this will avoid the asymmetric routing issues.

Please check these points and confirm if it works!

 

 

View solution in original post

3 REPLIES 3

Hi  Node is showing unknown because you haven't configured any node specific health monitor while configuring the node. Now your virtual server is showing available it means the backend pool is available and the pool member is listening as well as reachable on the required web-service port. So with this configuration, you should be good.

 

Now coming to the issue that web app not accessible from client system, i would recommend you to check the traffic hits on the virtual server as well as pool under statistics. This will clarify that the request is reaching the F5 virtual server and hitting the correct pool members.

 

If traffic is reaching properly, then check the SNAT (Source Address Translation) settings on the virtual server. If backend web-server don't have F5 as its default gateway, you need to enable SNAT (Source Address Translation) settings on the virtual server and you can set it to Auto-map. Basically this will avoid the asymmetric routing issues.

Please check these points and confirm if it works!

 

 

Hi  ,

 

Thanks for the help bro it is now working, your right everything is working fine, i just noticed that i have assigned an incorrect External IP that are not connected into any network. Also i change the SNA into auto-map and it is now working as expected ๐Ÿ™‚ .. BTW sir do you have an idea on how to fixed my HA configuration because when i tried to create an HA between my 2 BigIP i have an error show "Not all deviced Synced". Again thank you sir ๐Ÿ™‚

 

Thank you and God Bless,

Renato

 

Hi  , You're welcome!

For config sync, did you tried the recommendations given?