Technical Forum
Ask questions. Discover Answers.
Showing results for 
Search instead for 
Did you mean: 

How to configure the AOM for rSeries hardware appliance



As I encountered something when I want to shutdown the rSeries hardware appliance with F5OS 1.3.1 by CLI "halt". The process as smooth and shown "The system was halted". But I tried to Power on the appliance via front panel touch screen NO any respond.

Therefore, I would like to configure the AOM for remote control the rSeries Power On/Off the appliance.

But I just can apply the AOM networking settings, no any command for configure the AOM user such as CLI "aom_setup_user".


May you experienced this behavior or there have solution?

If so, don't mind share to us. Thank you very much.



Thanks and Best Regards,

Alvin Ng


Hi Jameswalter,

Thanks for your reply.

Yes, I have already checked this r5900 appliance mode not enabled currently.

Therefore, I tried to follow another platform KB - K11400446 (iSeries Reference). I just can apply the AOM networking settings such as IPv4 address, subnet mask, and default gateway by "esc + (" key, and able to access it through SSH. But login failed.

I tried to following the steps to create AOM users from KB - K11400446 but not positive with below result.

[root@appliance-1(BIGIPr5900) ~]# aom_setup_user

bash: aom_setup_user: command not found

[root@appliance-1(BIGIPr5900) ~]# aom_setup_user -o

bash: aom_setup_user: command not found

[root@appliance-1(BIGIPr5900) ~]# aom_setup_user -l

bash: aom_setup_user: command not found

[root@appliance-1(BIGIPr5900) ~]#


Just for your reference.

Thanks and Best Regards,

Alvin Ng

So, has anyone been able to set up AOM and or LOP to be able to remotely power cycle the host subsystem of an R series appliance (without using the serial console but rather using a management IP address)?

Alvin is correct in that the new AOM menu does not have a network config option and only seems to work from the serial console rather than from an ssh session. He is also correct in that the old aom_setup_user CLI command can not be found.


I just heard back from F5 support and they are working on ssh access to AOM for the R5900 Series. It is internally tracked as Bug ID 1282025 - "[RFE] F5OS AOM SSH access like iSeries".

Hi John,

Thanks for your information.

Don't mind me sharing more.

Yes, I tried different F5OS version between 1.3.1 and 1.4.0 in my RSeries appliance. That can configure the AOM interface network settings and able to access by SSH method similar as iSeries of pressing "Esc + (" to configure.

But I stuck in login process. I think there is same of sepate user account for AOM. Therefore, I tried to apply "aom_setup_user" CLI but not work.

I think that will be update to fix it this soon.


Thanks and Best Regards,

Alvin Ng

Hi, I had a similar experience.  I am now waiting to hear back from my F5 account team on an estimated date for them to have that done. I'll be happy when the AOM part of the R series works like the older I series.




If the power was turned off with the "halt -p" command, you should be able to power on using the touch panel.

Please note K22954168.


Thanks for your sharing.

Let me try it in my rSeries appliance. If it is fine, I will use this method rather than configure AOM.

SInce my concern as no any respond to power on the appliance from touch screen before, and require to unplug and re-plug the power pord action. That make me create the post to discuss how configure the AOM on rSeries.


Thanks and Best Regards,

Alvin Ng

With the F5OS the AOM is also called now LOP (Lights Out Processor)  , so search for info about it.

Pretty sure you have that backward - LOP is now called AOM - starting circa version 11 and the iSeries units (after the buffalo jumps). Mine (an rSeries unit) has "AOM" on the front LCD panel for the info/config.