cancel
Showing results for 
Search instead for 
Did you mean: 

F5 telemetry config

Dazni
Nimbostratus
Nimbostratus

Hello,

 

I'm trying to configure the F5 telemetry streaming on a Big-IP VE to forward the telemtry data to a Splunk server.

As described in the following article : https://devcentral.f5.com/s/articles/How-I-did-it-Visualizing-Data-with-F5-TS-and-Splunk

 

I have an issue with the steps 2 and 3 of the "Associate Logging Profiles to Virtual Server" part :

On my VS, I don't have the choice to select an HTTP, TCP or request logging profile, I don't have these parameters.

 

I don't understand what I am missing. Do I need another module (I only have a licence for the LTM module) ?

 

Regards,

Daz

 

 

1 ACCEPTED SOLUTION

CA_Valli
Cirrocumulus
Cirrocumulus

Hello Daz,

I'm relying on my memory so this info might be incomplete -- I believe that these profiles come from AVR module.

AVR is free with every bigip license, and if I'm not wrong it can be provisioned on VE's with minimal memory/disk requirements (I recall that memory/disk requirements for VE's usually depend on module allocation and AVR is always seen as an exception to module number)

 

Check your licensing & privisioning first, then check if your VS is standard-type (ip forwarding, fastl4 and other types of Virtual Servers might differ in configuration options) and then check if you're exploding "Advanced" configuration options as the guide says, in drop-down menu

 

EDIT - Adding a bit: profile selection at point 3 requires you to have WAF license. You can skip this if WAF does not concern your configuration IMO.

 

Hope this helps

CA

 

 

View solution in original post

3 REPLIES 3

CA_Valli
Cirrocumulus
Cirrocumulus

Hello Daz,

I'm relying on my memory so this info might be incomplete -- I believe that these profiles come from AVR module.

AVR is free with every bigip license, and if I'm not wrong it can be provisioned on VE's with minimal memory/disk requirements (I recall that memory/disk requirements for VE's usually depend on module allocation and AVR is always seen as an exception to module number)

 

Check your licensing & privisioning first, then check if your VS is standard-type (ip forwarding, fastl4 and other types of Virtual Servers might differ in configuration options) and then check if you're exploding "Advanced" configuration options as the guide says, in drop-down menu

 

EDIT - Adding a bit: profile selection at point 3 requires you to have WAF license. You can skip this if WAF does not concern your configuration IMO.

 

Hope this helps

CA

 

 

Dazni
Nimbostratus
Nimbostratus

Hello,

 

The Big-IP is licensed for the LTM module only and all the VS are standard VS.

I'll try to enable the AVR module this week.

 

Thank you for your help !

 

Daz

 

Dazni
Nimbostratus
Nimbostratus

Hello,

AVR provisionned => I have the analytics profiles options on the VS settings now.

Thank you   !

 

Daz