Technical Forum
Ask questions. Discover Answers.
cancel
Showing results for 
Search instead for 
Did you mean: 

Diagnose the LB_FAILED Event

Maria123
Altostratus
Altostratus

FB_FAILED is occurring even if all the server nodes are available. In the iRule logged the [event info] but noting is coming.

 

Is there any way to identify or diagnose the reason for this?

 

The tcp profile associated with the virtual server has "Maximum Syn Retransmissions" set to 3 currently.

 

The tcp monitor is having interval set to 5 secs and timeout set to 16 secs.

 

Will increasing the "Maximum Syn Retransmissions" or monitor timeout or interval improve on this?

 

3 REPLIES 3

Lee_Sutcliffe
Nacreous
Nacreous

make sure your pool members have a route back via F5, sounds like a routing issue. LB_FAILED happens when the TCP handshake to the pool member is not completed successfully.

 

Try enabling auto-snat

 

I’m guessing you are using gateway_icmp as a health monitor (which is connectionless). This will mark your pool up, however a TCP connection might fail as it require a working return path via the F5

 

Sam_D_
Altostratus
Altostratus

Hei Maria, we are now encountering the similar issue where BigIP works as load balancer before 3 LDAP servers. It'll be really appreciated if you could share your solution with me. Thanks in advance!

skunk
Nimbostratus
Nimbostratus

Hello Maria,

We do have the same situation here: all PoolMember show UP, iRule event LB_Failed gets triggered and Event_Info is empty 😞

Max_Syn_Retransmit is set to 5 - no difference.

We do SNAT, so return path is fine ...

Could you please share your solution? Thanks in advance!