cancel
Showing results for 
Search instead for 
Did you mean: 

Change BigIP hostname in AWS

JeffW_124536
Nimbostratus
Nimbostratus

How can I change the hostname of my F5 BigIP instance in AWS? I have changed it through the GUI and from CLI. The hostname does change but then when I reboot the instance the original ip hostname comes back.

 

6 REPLIES 6

Kosan_Koh_51462
Historic F5 Account
I am able to change the hostname via the BIG-IP GUI/CLI on v12 and do not have the issue you described after a reboot(either through AWS or BIG-IP). The new hostname sticks. What version of F5 BIG-IP instance are you running on AWS? Can you reproduce the issue?

JeffW_124536
Nimbostratus
Nimbostratus

Once the hostname is changed then run the below commands. It will configure the BIGIP to not get its hostname from dhcp in AWS. 1. tmsh modify sys management-dhcp sys-mgmt-dhcp-config request-options delete { host-name } 2. save sys config

 

JeffW_124536
Nimbostratus
Nimbostratus

I am running version 11.6. I found out how to change the hostname and make it stick. Once the hostname is changed then run the below commands. It will configure the BIGIP to not get its hostname from dhcp.

 

1. tmsh modify sys management-dhcp sys-mgmt-dhcp-config request-options delete { host-name } 2. save sys config

 

I have tried this several times on my AWS LTMs and it does not work. They always go back to the DHCP hostname. I am running 11.6.1. What happens is I change the hostname. Then I run the commands suggested. Then in about 15 minutes or so it just goes right back to the DHCP hostname. I have 6 AWS instances that have this issue.

 

As a follow-up. I opened a case regarding this issue and the following commands resolved this issue:

 

modify sys management-dhcp sys-mgmt-dhcp-config request-options delete { host-name } save sys config modify sys global-settings hostname denbigipname01.bubbles.com save sys config reboot

 

PhillyPDXMike
Nimbostratus
Nimbostratus

The link below answers this question with an official KB article for 12.X & 13.X AWS BIG-IP VE instances:

 

https://support.f5.com/csp/article/K45728203

 

Also, this behavior is referenced as bug ID744740:

 

https://cdn.f5.com/product/bugtracker/ID744740.html

NOTE: The procedure in the above BUG ID link worked on my 14.1.2.6 AWS BIG-IP VE w/ the addition of the modify hostname command.

 

bash

tmsh modify /sys global-settings hostname big-ip-hostname

tmsh modify sys global-settings mgmt-dhcp disabled

tmsh modify sys global-settings mgmt-dhcp enabled

tmsh save sys config