cancel
Showing results for 
Search instead for 
Did you mean: 
Login & Join the DevCentral Connects Group to watch the Recorded LiveStream (May 12) on Basic iControl Security - show notes included.

ASM Custom Block Page seems not working from GUI.

Seckin
Cirrus
Cirrus

Hi everybody, we are trying to do differenrt custom blocking page on ASM but it seems to freeze when we are using custom one. I have tried custom html code in my lab and it works ok. Do you have any thoughts about this issue?

1 ACCEPTED SOLUTION

Ok, this sounds like a bug. You should open a support case. There will probably be an error logged in a log file at the time you try to save the custom response, so include a QKView with the case.

View solution in original post

5 REPLIES 5

eey0re
Cirrostratus
Cirrostratus

What freezes - saving the custom response in the ASM Config Utility, or actually sending the response to the user when their request is blocked?

 

If it's the latter, are you loading other page elements in the custom HTML? What does the browser inspector show (F12 > Network tab)?

 

If the former, what is your ASM version? I would check some logs when you save the page, such as /var/log/asm, recently changed files in /var/log/ts, others recently changed log files.

Hi, we can not upload or change the custom response page from GUI. GUI stuck when we save the new response page and takes so long time which is not usual.

Ok, this sounds like a bug. You should open a support case. There will probably be an error logged in a log file at the time you try to save the custom response, so include a QKView with the case.

Thanks dude. I opened a support case and its bug that you said. After engineering hotfix applied, fixed. Thanks...

please select the answer as the correct one then.