Forum Discussion

Ruchir_79916's avatar
Icon for Nimbostratus rankNimbostratus
Nov 16, 2011

Using VS for port forwarding

Hey guys,





This is very simple config, which has been troubling me a bit. I am trying to do this:




My webserver is running with 2 ports active 80 and 8080




Now this is what I am doing, point one domain directly to port 80 IP and then on LTM create a VS with service port 80 and in pool add server with port 8080, but for some reason, It doesn't forward anything to pool, I can not see anything in log, anyone has a clue ..




or is there something I am doing wrong ..


8 Replies

  • does the LTM have a route to your server, and if the LTM is not the default gateway for your server, have you enabled snat automap or added a snat pool?
  • LTM can reach to server just fine .. Pool shows available and check is working too, but doesn't forward request ..
  • can you post output of these commands?



    b virtual virtual_server_name list


    b pool pool_name list
  • Here:


    Virtual list:



    virtual {


    translate address disable


    translate service disable






    ip protocol tcp


    clone pools clientside





    Pool List:


    pool {


    monitor all tcp


    members {}


  • can you try this?



    b virtual snat automap translate address enable translate service enable
  • awesome, that worked, do you mind explain what you think reason was ??of course.



    snat automap - this will translate source ip to selfip address when bigip sends traffic to pool member. snat is required to force return traffic going to bigip in case pool member's default gateway is not bigip or client and pool member is in same subnet.



    translate address enable - this will translate destination ip address from virtual server address to pool member ip address e.g. to



    translate service enable - this will translate destination service port from virtual server service port to pool member service port e.g. 80 to 8080.



    all of these are able to configure via webui as well. they are under virtual server setting but you have to change configuration combo box from basic to advance to display these options.



    hope this helps.