Forum Discussion

Adam_Ingle_1300's avatar
Nov 06, 2017

Unable to Modify Imported iRules LX Workspace Elements

Ran into a unique issue when trying to "Import From Workspace" ilx workspaces. The import process seemed to work properly, however, I was unable to change the rules, extensions, etc. Could not add, could not delete, nothing.

 

When importing workspaces, it's really handy to be able to import "From Workspace." Saves a step if you're wanting to rename for a different virtual-server or create a duplicate/backup.

 

However, different from exporting and re-importing, the "From Workspace" option seems to miss a step which removes critical rights the system needs to be able to manipulate the copied directory properly.

 

Here's the issue and the fix:

 

Import "From Workspace" works correctly in the GUI it appears

 

However, upon trying to add/modify/delete anything associated, you see it cannot be saved. (Insert Price Is Right Horn)

 

From the CLI bash, you can see the file's permissions don't look the same as the others. chmod that sucker to good ole 777 with the recursive option and that'll fix ya.

 

Now, from the GUI, you're free to make all the changes you need.

 

This is different than exporting off the BigIP and re-importing from off-box. That appears to copy with the proper file permissions and no issues are seen there. But on-box import, while it does import, does not do so properly. If you're not comfortable with chmod, please export the workspace off-box and then re-import from the archive. This will prevent the permissions issue that cause issues saving changes.

 

Hope this helps!

 

5 Replies

  • Adam,

     

    Thank you for sharing the permission issue with the iLX's import function. I tried the feature, and got the same result (on 12.1.2/VM). Will investigate.

     

    Note: Import "From Plugin" also has the permission issue too.

     

    Satoshi @ F5

     

  • Adam,

     

    We have identified the behaviour as an issue and will address it in a future release.

     

    Thank you again for reporting it and providing effective workarounds.

     

    Satoshi @ F5

     

  • I'm getting the same error in 15.1.5.  Was this ever resolved?  I'm getting the same error when trying to modify and imported Workspace.

    • Leslie_Hubertus's avatar
      Leslie_Hubertus
      Ret. Employee

      Hi jba3126 - sorry for the long delay in reply! I didn't see your question on this old thread until today. Satoshi-san isn't with the company anymore, but JRahm may be able to answer. 

      • jba3126's avatar
        jba3126
        Icon for Cirrus rankCirrus

        Leslie_Hubertus No worries.  I ran the permissions change/update and rebooted with no success; however when I updated to 15.1.5.1 and it imported just fine. 🤔