flipa_29928
Mar 08, 2011Nimbostratus
The F5 Monitoring Service Data Source Singleton Error
Hi All,
Recently installed the F5 Management Pack as per the WIKI guide (RMS first then the Management Server to be used for F5 discovery/monitoring).
Today we attempted our first discovery of an F5 device and as we wanted to confirm whether or not the big3d agent might be upgraded and possibly cause some impact we chose to discover the standby node of our F5 load balancers.
One of the F5 Administrators used his account named account which is a member of the Administrator role on the F5 appliances to perform the discovery task on the management server.
The discovery completed successfully and eventually the device appeared in the appropriate F5 Management Pack state view with a green tick.
I then noticed, however, an alert in the SCOM Console's Active Alerts view relating to the F5 Management Pack Monitoring Service on the designated Management Server that the discovery was performed on.
If I expand the Health Explorer for the F5 Monitoring Service on this Management Server I can see the following roll-ups are Critical:
+Entity Health
+Availability
+Data Layer
+Operations Manager Connections: - F5.MonitoringService (F5 management Pack Monitoring Service)
+Data Source Server - F5.MonitoringService (F5 Management Pack Monitoring Service)
+Operations Manager Connector - F5.MonitoringService (F5 Management Pack Monitoring Service)
Clicking on the bottom two unit monitors to see what Knowledge text they have shows nothing and the State Change history tab is as follows:
+Data Source Server - F5.MonitoringService (F5 Management Pack Monitoring Service)
Description: The PerformanceDataSourceConnector connection to Operations Manager Health Service host localhost was lost: Failed to connect to an
IPC Port: The system cannot find the file specified.
+Operations Manager Connector - F5.MonitoringService (F5 Management Pack Monitoring Service)
Description: The PerformanceDataSourceConnector connection to Operations Manager Health Service host localhost was lost: Failed to connect to an
IPC Port: The system cannot find the file specified.
In the Active Alerts view there is also the error named, "F5 Monitoring Service data Source Singleton error" and the Path of this error is the Management Server from which the discovery task was run. The Description text for this error states: "The F5 Monitoring Service data source been loaded multiple times. "
The Knowledge text state:
Summary
The F5 Monitoring Service data source been loaded multiple times.
Configuration
Configuration of threshold and performance data rule overrides is part of Operations Manager override interface.
Causes
This most frequently occurs when rule overrides for thresholds or performance data collection are targeting incorrect objects.
Resolutions
Please attempt to fix or reset your rule overrides for thresholds and performance rules.
Additional Information For additional information about the F5 Management Pack rule overrides, refer to the Management Pack Rule Override Wiki at: http://devcentral.f5.com/wiki/default.aspx/MgmtPack/PerformanceCollectionAndMonitoring.html
External Knowledge Sources
External knowledge sources. http://devcentral.f5.com/mpack
At this stage no additional configuration has been done to any rules or collectors for performance or availability monitoring. The only thing that has ben done is to discover the device and let whatever default object discovery tasks are enabled to run to see what gets populated. Our plan is to turn-on any desired performance and object discoveries as required once we get the Active node into the configuration.
However, before we get to that I would like to understand and fix this f5 Monitoring Service data Source Singleton error.
So, if anyone can explain the meaning of this error and how it can be resolved I would bemost grateful. Is the error just the F5 Management Pack's way of saying we need to configure overrides if we expect to get any meaningful monitoring of the devices? Do I simply need to restart the F5 Monitoring Service on the Management Server resolve this?
Thanking you for your considered reply,
flipa