Forum Discussion

Matt_Jannusch's avatar
Icon for Nimbostratus rankNimbostratus
Mar 15, 2012

Partition default route domain

I'm trying to configure a route domain to be a partition default, and each time I go to the route domain configuration I want to apply, and select the "Make this route domain the partition default route domain" option, the LTM comes back with "0107082e:3: The default route domain cannot be changed for the 'Test' partition." The Test partition contains the newly added route domain, and the VLAN(s) that I created for this route domain. Other than that, there's nothing defined in that Test partition.



From what I read in the documentation, for this to work the route domain being assigned must not reside in the Common partition. I've got that - the RD exists in the "Test" partition. I'd maybe expect to see this sort of error if anything else was configured in the partition, but these are real bare-bones sorts of things. If I delete the VLANs from the partition, that makes no difference. There are no self-IPs or floating-self-IPs in the partition or on those VLANs, no Nodes, no Pool Members, no virtual servers, etc.



It just doesn't seem to be working as described. What am I missing?



Also, and I hope there's a way around this - it appears that a route domain that isn't in the Common partition can only be assigned as the default in the partition it resides in. Is that the case, or can I assign the route domain to multiple partitions as their default route domain?






10 Replies

  • you are running 11.x, aren't you? if so, i suspect you are experiencing bug 361358 which will be fixed in 11.2.0.



    can you open a support case for verification? i am not sure if they are able to provide you engineering hotfix.
  • Did you hear back? I'm having the same problem on 11.1 HF2 on a lab virtual edition.
  • Has anyone heard back on this. I have the same problem on 11.1.0 HF2. This worked in v10.
  • as i know, the fix cannot be done in hotfix. so, it seems you have to wait until 11.2.0.
  • Hi guys


    hello amigos!



    so im going live in approximately 25 days on a $140 000 000 (million USD.) project. Im writing from Bogota Colombia currently working on one of the biggest projects ever using F5 boxes (2 viprion chasis 2400 with 4 blades each) for the biggest education institution in Colombia: SENA



    today my teammates and I ran into this problem which alerted the heck out of us because like I said above... we are going live in about 25 days....



    I know that nitass post was about 10 days ago but any updates on this? any workaround yet found ?



    This issue will dramatically impact on the current desing which will bring down the entire project!!



    any offical word on F5 ?



    thanks in avdanced
  • Hi Glenn,



    If you're looking for official statements from F5 you should open a case with F5 Support. As far as I can see, I think BZ361358 can only be fixed in 11.2.0 and not in a hotfix for 11.1.x. So you'll either need to work around the issue or escalate this with F5 Support and your account team.



  • i suggest opening a support case to verify the bug and check when 11.2.0 is available (if possible).
  • Hamish's avatar
    Icon for Cirrocumulus rankCirrocumulus
    Is the bug just for the web interface? on a (non-live obviously :) system, what happens if you manually edit the config file to do what you want, and then do a load of the config?





  • Hoolio/nitass/Hamish



    Thansk a lot for your quick responses! We already escalate this with F5 support and PD in order to expedite things for us...


    I'll keep you posted in this



    on the other hand,






    I tried to run the TMSH command: modify auth partition default-route-domain but I got the same error as in the GUI: 0107082e:3: The default route domain cannot be changed for the partition.



    I have not try to manually edit the config file but I'll give it a shot this today to see what happens



    I'll keep you posted as well






  • Actually you can set up a different route domain with 11.1 :


    1) Make a partition


    2) Make a route domain inside that partition


    3) add vlans and add the vlans to that route domain


    4) add a selfip with the RD id: x.x.x.x%RDID


    5) add route domain default route with destination


    6) add a virtualhost with the RD id in the ip x.x.x.x%RDID




    Keep in mind to add %RDID to the end of the IP addresses you are going to use inside that route romain. And there it is a different RD in every partition.