Forum Discussion

sukru_isik_8872's avatar
Icon for Nimbostratus rankNimbostratus
Aug 05, 2013

no space left on device

I have a f5 3900 and I have a disk problem.when I want to take a ucs file,I see an error like that:


"can't write temp config file "bigip.conf",in temp dir "/.config.tmp/xI06TM",No space left on device "


Filesystem Size Used Avail Use% Mounted on





287M 287M 0 100% /




3.0G 86M 2.8G 3% /config


/dev/mapper/vg--db--sda-set.1._usr2.0G 1.5G 401M 80% /usr




3.0G 352M 2.5G 13% /var




30G 196M 28G 1% /shared




6.9G 367M 6.2G 6% /var/log


none 4.0G 708K 4.0G 1% /dev/shm


none 4.0G 16M 3.9G 1% /var/tmstat


none 4.0G 1.3M 4.0G 1% /var/run


prompt 4.0M 28K 4.0M 1% /var/prompt


/dev/mapper/vg--db--sda-app.ASWADB.set.1.mysqldb12G 2.9G 8.4G 26% /var/lib/mysql


none 4.0G 8.0K 4.0G 1% /var/logd




3.8G 65M 3.5G 2% /shared/avr




what can I do about that?is there anyone experinces this issue?


5 Replies

  • /dev/mapper/vg--db--sda-set.1.root


    287M 287M 0 100% /what eats up space on root (/)?
  • shaggy's avatar
    Icon for Nimbostratus rankNimbostratus

    SOL14403: Maintaining disk space on the BIG-IP system (11.x)


    SOL12263: Maintaining disk space on the BIG-IP system (9.x - 10.x)


    I have run into issues in the past with admins using their /home/ folders, which are in the root partitions, for file storage instead of in the /shared/ partition.


  • Sil's avatar
    Icon for Nimbostratus rankNimbostratus

    I run into the same question: what eats up space on root?


    Why there are only 427M total space for / ex works? Actually we have 58M free space, only 14%. Is this critical? What to do? We dont stored any datas on the f5, no tcpdumps, no stuff in home directories and so on.


    Is 58M free space enough for the f5 to work in a stable and performant way? Or do we have to adjust the partition structure?


    I hope someone can help :-)


    Update: we solved it, it was our fault - we monitor our f5's with ansible and did not set the parameter keep_remote_files=false


  • Hi,

    When I have faced such issue, I have removed unwanted files with .gz and .tar extensions in /var folder.

    Also I have removed all files in /tmp folder.

    Usually BIGIP images also occupies more space. It is recommened to remove unwanted bigip image files.