Forum Discussion

Dathan_88557's avatar
Icon for Nimbostratus rankNimbostratus
Jul 21, 2011

New Virtual Server doesnt work

Hi Friends,



I am having an F5 Load balancer 1600 (BIG-IP 9.4.7 Build 320.1 Final)currently in production. I am having 11 Virtual Servers (7 Virtual IP's with different ports) and 11 Pools. i have a total of 14 nodes. I tried creating a 12th Virtual Server and tried load balancing. But it doesn't works. I can reach the new Virtual IP on the port that i have created on the Load Balancer. The load balancer also detects the nodes and it shows it is active. When i manually disable the Node, i can also see my maintenance page that i have created using iRule. But i cant see the page from the particular node. I have done the same configuration that i have done for the working Virtual Servers but still it doesn't works. I have spent almost 2 days on investigating on this but didn't find any clue.



Is there any limitation on the No: of Virtual Servers that can create in a LB? or else, what might be the cause of my issue. I didnt face these issue before. Please help me if anyone have any info.



Thanks and Regards




3 Replies

  • Hi Dathan,



    It sounds like the server(s) in the pool don't have their default gateway set to an LTM self IP on their subnet. If you can change this setting on the servers, you can leave the LTM config as it is. Else, if you can't change the servers, you can enable SNAT on the virtual server.



    If that's not it, I'd start with a tcpdump to see what's happening on the serverside:



    tcpdump -ni 0.0 -Xs0 host CLIENT_IP or host SERVER_IP



  • Hi Aaron,



    Wow..thanks a lot for your great help. As per your advice, i have just enabled SNAT Pool to "Auto Map" and it works perfectly. Thanks a lot for your help and i really apologise for asking this question if it is really basic. Sorry i am very new to F5.



    Thanks and Regards


  • Keep in mind that Autosnat will hide the real address of the client if you attempt to look at any logs in the nodes.