Forum Discussion

AlaaIbrahim's avatar
Icon for Nimbostratus rankNimbostratus
Dec 24, 2023

Migration to rSeries using Journeys

Hello All!

We were trying to migrate from VE Big-IP v16.1.3.2 to rSeries 2600.

Removed all device group config from the configuration, configured VLANs, LAGs and Interfaces manually and tried to use Journeys for the migration. However when enter the destination IP and the credentials in Journeys we get the following error:

 Error encountered / cannot proceed: mcpd is not in the running phase. Before executing any command related to UCS save/load, mcpd must be in the running phase. Run 'load sys config' on the BIG-IP: x.x.x.x o further diagnose the problem or load your backup UCS archive to restore the system.

Any idea how to solve this issue? also if someone did this migration before would you share your notes


Thanks in advance!

5 Replies

  • Frequently the issue is networking - different VLAN names etc, or that the target device has the wrong master key.

    If you have tried to load the UCS onto the target device and it fails, check the /var/log/ltm file to see why it fails and troubleshoot from there. If you use tmsh show sys mcp-state that should give you a clue as to where the issue is generally and you can then dig into this further. This may also be useful: 

  • Hello,

    I would suggest an other approach

    From the migration point of view you are trying to migrate from a VE to an rSeries wich is not the same platform.

    Therefore, there will be some concerns.

    1. If you have already configured networking, connect to the r2600 and copy /config/bigip_base.conf (vlan names should be the same)
    2. On the old VE run f5mku -K to retrieve the current master key, put it on notepad (we will use it soon)
    3. On the r2600 run f5mku -r <paste VE MasterKey> 
    4. On the VE generate a fresh ucs
    5. On the r2600 upload the VE ucs, and run tmsh load sys ucs <ucsname> -no-license -no-platform-check 
    6. Configuration will fail to load because of networking 
    7. on r2600 rename the existing /config/bigip_base.conf to bigip-base.conf.bak1 upload the bigip_base.conf you downloaded in step1 and run tmsh load sys config base.
    8. The network config should be loaded
    9. Run tmsh load sys config, config should be able to load correctly

    Note :

    • Always take a backup ucs before any step
    • Target r2600 should have at least the same licensing as the source bigip VE.
    • If your F5 is in production env refer to F5 support for assistance




  • i suggest to use the gui or tmsh mechanism rather than editing files.
    i had failed planned activity in 2013 even though the file editing procedures was made by f5 professional services.

    btw, in poc with f5 engineer in 2011, i was able to pair viprion with VE that persistence keys were also synchronized
    they definitely has different physical port layout.
    so you can try pair the ve with r2600 then break the pair after shared config are synchronized.
    if you have second r2600, set the HA pair after it.

    • yakai's avatar
      Icon for Cirrus rankCirrus


      Using GUI and clustering approach is good, however there are some requirements you have to satisfy :

      You should have connectivity between VE and your target r2600 (which is not the case all the time). Moreover performing this action on production env may cause a down time.

      UCS approach does not require neither file editing nor connectivity , and I personally performed it manu time with big success and no down time.


  • instead directly pair the existing ve with the r2600, you can:
    a. copy the existing ve image then run it in laptop using vmware player/ hyperv / etc.
    b. pair laptop ve with r2600 then unpair. you will have all the shared resources config, e.g virtual server, floating ip, etc. in the r2600.
    c. make ip addresses changes on the r2600 accordingly