Forum Discussion

vipin_96627's avatar
vipin_96627
Icon for Nimbostratus rankNimbostratus
Jun 15, 2012

LocalLB.ProfileDNS.get_list behaving incorrectly

Hi,

 

 

I have a problem with f5 API LocalLB.ProfileDNS.get_list(). This function sometimes returns nothing even though I can see DNS profiles in the LocalLB. I tried this using pycontrol i Control API and also tried with gSoap.

 

 

 

This is a inconsistent behaviour. Any idea why it is like this...

 

 

 

one more question if the above API doesn't work, Is there any way to find out a profile in a virtual server (LocalLB::VirtualServer) is a DNS profile or not?

 

 

 

Thanks,

 

Vipin

 

2 Replies

  • It'd be odd for it to fail. Can you characterize any more fully what you're experiencing when it fails?

     

     

    Could it be that your profiles are in another folder than the active one and you do not have System::Session recursive path setting enabled?

     

     

    Next time it happens, post the tmsh command and output that corresponds to the iControl call and return. You can also turn on some internal debugging to see what is going on if you are game to do that (iControl queries an internal process named mcpd, and you can turn on the mcpd log temporarily to see what iControl sends it and what it returns). You can also dump the table on the bigip using "guishell -c select * from profile_dns" and that might be a good thing to post here next time it happens.

     

  • Oh, re your last question I think the profile type is returned with the get_profile return value, like this example:

     

     

    >>> b.LocalLB.VirtualServer.get_profile(['v1'])

     

    [[{'profile_name': '/Common/fastL4', 'profile_context': 'PROFILE_CONTEXT_TYPE_ALL', 'profile_type': 'PROFILE_TYPE_FAST_L4'}]]

     

     

    See the PROFILE_TYPE_FAST_L4?

     

     

    Also, if you posted the results of that method above when you get the weird get_list result, that will help because it might reveal the reference was to a folder other than /Common, for example.