Forum Discussion

mr_skater99_640's avatar
Icon for Nimbostratus rankNimbostratus
Aug 04, 2011

iControl error during EM discovery

Hi all,



I'm trying to discover a v9 device and i'm getting the following in the EM console:



getSlotInfo: iControl error: 'iControl::OperationFailed - primary code:16908289(0x1020001) secondary code: 0(0x0) string: Error generating boot image information'



Can anyone shed some light on this guy? Can't find much anywhere (un-managed device is working well).








10 Replies

  • Still getting this error - but now with a different device running 10.0.1 build 378



    Any ideas?
  • there is a similar problem in the KB (, though with a different reason (copying files).



    Can you please enable iControl debugging, according to SOL7823 (



    I'm pretty sure you/we will find the error in the debug logs or in the decrypted communication.



    BTW: What's your EM version?





    Kurt Knochner
  • Ok so i upped our EM to 2.2 - same error. I followed the steps here to turn on debugging - ( and the discovery worked first go?1?

    I followed the steps here to turn on debugging - (


    sr=17369566) and the discovery worked first go?1?




    well, debugging is not supposed to fix the problem, but rather identify it :-))



    Probably the "bug" has been fixed in 2.2. Please disable debugging again and re-check.





    Kurt Knochner
  • I'm getting this error and I'm running EM 3.1.0 Build 1757.0 Final. Any recommendations would be appreciated.


  • Brian_102545's avatar
    Historic F5 Account

    try a 'tmsh restart sys service httpd' on the device you are trying to discover


    • MichaelM's avatar
      Icon for Altostratus rankAltostratus

      Thanks. This solved my device detecting issue (iControl::OperationFailed ... error getting service status) between EM 3.1.1 HF6 and BigIP 11.5.4 HF1 (using big3d v12. as data collection agent).


  • I tried the command however it did not resolve the issue.


    It should be noted the target LTM device is running BIG-IP 9.3.1 Build 37.1.


    Any other suggestions/recommendations will be greatly appreciated. Thanks.


  • Joe_M's avatar
    Icon for Nimbostratus rankNimbostratus

    9.3.1 doesn't have TMSH so you should do a "bigstart restart httpd" and personally, I would also restart tomcat, "bigstart restart tomcat". If that still doesn't work, I would reboot the LTM using "full_box_reboot". That Build also indicates you don't have any hotfixes installed. I would also recommend installing HF8 for 9.3.1. As a side note, F5 has terminated ALL v9 support as of 8/31/2013.