Forum Discussion

netteam_66633's avatar
Icon for Nimbostratus rankNimbostratus
Jan 11, 2011

How to monitor memory utilization using F5 MP





I'm interested on monitoring Memory utilization for TMM and Others domains, and be able to see the percentage used the same way it's displayed on


Performance Dashboard.


I've created a new MP and using a performance view I tried to display using 2 rules, Global Memory and Global Memory Used but nothing got displayed.






3 Replies

  • Julian_Balog_34's avatar
    Historic F5 Account



    I'd like to make sure first that you're getting the 'Global Memory' and 'Global Memory Used' stats, using the Performance View associated with the F5 Management Pack itself. In the SCOM Operations Console please go to Monitoring >> F5 Networks >> All Devices >> Diagram View >> select your F5 device >> right click >> Open >> Performance View >> check the 'Global Memory' and 'Global Memory Used' stats >> refresh the view a few times within a minute >> you should be getting the stats plotted.



    If you don't see any stats coming in, the next questions would be:



    1. Do you have any rule overrides defined for these stats? If yes, please zip and send your override pack to managementpack(at)f5(dot)com, so we can take a closer look to it.


    2. What is the version of the F5 Management Pack you're using? (regedit >> HKLM >> Software >> F5 Networks >> Management Pack >> Version)


    3. What is the F5 device platform version you're monitoring with the F5 Management Pack?



    Let us know.





  • Julian,



    I've followed your instructions and I wasn't able to see any stats. For some units I can see Global Memory for some not. I've sent the logs for review, because I opened another thread about stability of the F5 monitoring service.



    1. We didn't create any overrides yet, it works with all default settings.



    2. We are using v2.1.5.440 - x64



    3. We have 4 F5 BigIP 6400, running 10.0.0 TMOS







  • I ran the discovery couple of times and kept refreshing the collection rules and I've seen more counter and for some of them data is plotted. But still I'm not able to see all of them in each unit. Sometimes when I run f5mpcmd /RCR from cli


    it returns an error saying that the monitoring service is not available even if the service is running. I had to stop and restart it few times then it runs successfully.