Forum Discussion

Anthony_Cheng_1's avatar
Icon for Nimbostratus rankNimbostratus
Apr 23, 2014

GTM adding LTM as server - Reason no reply from big3d : timed out

I am currently trying to setup a GTM and adding a HA LTM pairs as a server. I use the self-IP on the vlan that both the LTM/GTM are on and put "bigip" as the Health monitor. Added both LTMs via the bigip_add in the GTM.


I have autodiscovery enabled for the Virtual Server (VS) but none of the VS from the LTM are discovered. Then I tried to manually add in the VS but they don't show up as green either, from the CLI I see the reason given for the VS being down is:


Monitor /Common/bigip from : no reply from big3d : timed out


Pretty much stuck at this point, tried to re-add ssl via bigip_add. All LTM/GTM are sync to the same NTP server.


11 Replies

  • Could be multiple reasons, but usually indicates an inability of the two devices to communicate (access control or routing).


    First, are you adding the LTM pair as a BIG-IP System (Redundant)? It should be done this way rather than as individual BIG-IP systems.


    In order to see what is happening, try running iqdump to see if your GTM can talk to your LTM. Run this from the GTM CLI (bash prompt):


    iqdump LTMipaddress


  • Yes I am adding the LTM pair as a redundant pair. Actually if I remove all the manually created VS under the GTM group then the server is shown as green (this is probably default behavior if there is no VS to check I presume). So it does look like it's working but it is odd that no VS is being detected under that LTM group (unless it only detects a very specific type/class of VS).


    I also tried the IQDUMP as you suggested but it is not that clear what I should be looking for, I do see that under "server", there are traffic and it shows a status of 1 as active.


  • The iqdump suggestion was meant to ensure that your GTM and LTM were communicating properly with each other. If there's a big3d communication failure between the two units (which it seems there is according to your log message), iqdump should indicate that.


    So in the GTM under Global Traffic -> Servers, does the LTM HA pair server object show as green? And is it just the virtual server discovery is not working?


  • Yes the LTM HA pair does show up as green but no VS is being discovered even though I have active VS on the LTM.


  • Did you perform a big3d install from the GTM to your LTMs?



    If so, what versions of big3d are running on your GTM and LTM?


    big3d -v


  • I read that article before and I know I used "bigip_add" but I am not sure if I also used "big3d_install", anyway I used the latter now but still no VS.


    The LTMs/GTM are all running the same version (they are all running VE versions if that makes any difference).


  • Are you still seeing the bigip monitor timeout messages in the GTM log? If so it may indicate a communications problem between your GTM and LTMs. I see no other reason why this shouldn't be working. Can you verify that all of the supporting layer 2 and 3 networking is correct and that no layer 4-7 network devices are blocking communications?


  • Nope, no more error/timeout anymore when I do "show gtm server virtual-servers" as the VS are now mark as active.


    I can telnet to both LTM self-IPs (off the same vlan as the GTM) off 4353, and I can also telnet to the VS on the LTM off all its service ports (80/443/135). There is nothing else in between as they are all VMs (this is a lab environment which I am just doing some testing).


  • May be best to open a case with F5 support at this point. It sounds like everything is configured the way it should be.


    • stan_peachey_86's avatar
      Icon for Cirrus rankCirrus

      I had this same problem. The solution for me was adding the BIG-IP DNS (GTM) to its own server list. The LTM virtual server list populated a few minutes later