Forum Discussion

MITUSER_21710's avatar
MITUSER_21710
Icon for Nimbostratus rankNimbostratus
Sep 13, 2011

F5 BIG IP LTM v10 does not follow the given virtual server order

We have created few virtual serves one forwarding virtual server with 172.25.101.100:80 and a wildcard load-balancing virtual server with 0.0.0.0:80.

 

The issue is traffic coming to 172.25.101.100 on 80 is not matched to the forwarding virutal server and it is directly matched to wildcard virtual server.

 

 

Is this the normal behavior, if yes what we can do to match that specific traffic and froward to the destination rather than load-balanced by the wildcard virtual server

 

4 Replies

  • i think it should match 172.25.101.100:80. how do u know it doesn't match?

     

     

    sol6459: Change in Behavior: Order of precedence for virtual server matching

     

    http://support.f5.com/kb/en-us/solutions/public/6000/400/sol6459.html
  • Hi nitass

     

     

    I have read sol6459 earlier the issue is before v4 forwarding host had least priority, but after v9. they have not specifically mentioned the priority of the forwarding virtual servers.

     

    How we know is we see the packets on the wildcard virtual server pool when we do a tcpdump
  • sorry, you are correct.

    in my test, it hits wild virtual when telnet 209.85.175.103 80. will dig it further.

    [root@iris:Active] config  b virtual list
    virtual bar {
       translate address disable
       translate service disable
       ip forward
       snat automap
       destination 209.85.175.103:http
       ip protocol tcp
       profiles fastL4 {}
       vlans internal enable
    }
    virtual wild {
       snat automap
       pool foo
       destination any:http
       mask 0.0.0.0
       ip protocol tcp
    }
    
  • i did a little bit test and it appears traffic hits tcp virtual before fastl4 virtual server.

     

    [root@orchid:Active] config b virtual list

     

    virtual bar1 {

     

    ip forward

     

    destination any:any

     

    mask none

     

    }

     

    virtual bar2 {

     

    destination any:any

     

    mask none

     

    ip protocol tcp

     

    }

     

    [root@orchid:Active] config tcpdump -nni 0.0 port 80

     

    tcpdump: listening on 0.0

     

    18:23:38.020472 802.1Q vlan4094 P0 10.10.70.110.2001 > 8.8.8.8.80: S 3456383571:3456383571(0) win 5840 (DF) [tos 0x10]

     

    18:23:38.020513 802.1Q vlan4094 P0 8.8.8.8.80 > 10.10.70.110.2001: S 3948894867:3948894867(0) ack 3456383572 win 4380 (DF)

     

    18:23:38.020990 802.1Q vlan4094 P0 10.10.70.110.2001 > 8.8.8.8.80: . ack 1 win 1460 (DF) [tos 0x10]

     

    18:23:38.021045 802.1Q vlan4093 P0 10.10.70.110.2001 > 8.8.8.8.80: S 1391728281:1391728281(0) win 4380 (DF)