Forum Discussion

Hygor's avatar
Icon for Nimbostratus rankNimbostratus
Sep 21, 2017

Client Authentication error

I'm migrating a apache configuration to F5 LTM. My problem is when I need to authenticate the client using SSL. My configuration is working fine when a user try to access through Internet Explorer, but when I try to access through firefox generates this log message: ssl_codec_rx:1942: received alert (10) and the browser shows SSL_ERROR_RX_RECORD_TOO_LONG. If i try to access from Google Chrome, i receive this message in the log ssl_codec_rx:1942: received alert (22) and the browsers shows ERR_SSL_PROTOCOL_ERROR.


i'm using the following cipher list that is the same in use by apache DEFAULT:!ADH:RC4+RSA:+HIGH:!SSLv2:!EXP:!MD5:!LOW


4 Replies

  • Hi,


    If you are using client authentication for your application. You need to enable client authentication configuration on F5 SSL profile configurations.


    When you enable client authentication only users who has client certificates installed on browsers will be able to access application.


    Regards, Raghav


  • ms_g's avatar
    Icon for Nimbostratus rankNimbostratus

    Any idea ..if this is fixing the issue ? I have the same problem... The difference is that for some of the clients is working properly for other is not working and sometimes disabling and reenablin the network card solve the issue.


  • The latest browser reports "ERR_SSL_PROTOCOL_ERROR" error when connecting via HTTPS using LTM version V11. However, the connection works fine with V14. Could you please provide guidance on how to configure the SSL profile for V11 to ensure compatibility with the latest browsers?