Forum Discussion

richard_polyak's avatar
Icon for Altocumulus rankAltocumulus
Jul 20, 2021

BIG-IQ 8.1.0 and BIG-IP device Trust

Good day, I am hoping someone could assist on my issue.


I have upgraded our BIG-IQ from 8.0.1 to 8.1.0. During the the upgraded half of the 80+ devices lost it's Device Trust with BIG-IQ.


During the post BIG-IQ upgrade process, where you are to re-import the BIG-IP devices I received errors on half of the devices, and the status came back as "This device is not available.".


I manually went to the devices and tried to re-import the device, but I received the following error:

"Error getting resource provisioning from /mgmt/tm/sys/provision on xxxxxxxxxxxxxxxx (, Authorization failure - you may need to remove the device from BIG-IQ and add it again to reestablish trust"


So I was able to do this on devices that I have yet to declare any AS3 configurations, but it puts me in a catch 22 with devices I have. I am unable to remove these application services as the device trust is broken. I am unable to discover the device as trust is broken, and I am unable to remove device as application services are defined.


Does anybody know how to re-establish the device trust without destroying the AS3 configurations on the BIG-IP's? Any of the API's have not worked.

This does not work


I have a support case open with F5 but this has yet been resolved. This issue to me brings up a bigger problem, what would be the RMA process if you if you have AS3 declarations defined?


Thank you in advanced for any assistance.


1 Reply

  • Dojs's avatar
    Icon for Cirrostratus rankCirrostratus

    When i did the upgrade of my environment, i miss all my applications with AS3 and i had to setup all them in legacy mode.

    When I missed communication between BIP and BIQ, I ran the follow commands

    ### CLEAN BIG IQ on BIG IP ###

    mv /config/f5-rest-device-id /var/tmp 

    clear-rest-storage -l

    tmsh save sys config

    (optional) shutdown -r now



    clear-rest-storage -l -d