Forum Discussion

Gedeon_47787's avatar
Icon for Nimbostratus rankNimbostratus
Apr 13, 2011

Access to internet - issue from internal VLAN with SNAT

I need to configure an F5-LC to permit the hosts in the Internal VLAN have access to internet, and trying to use a SNAT:


· SNAT_Lab


o Translation: Pool_SNAT_Lab


o Address List: (PC in internal VLAN)


o VLAN Traffic: All VLANs


· Pool_SNAT_Lab


o Member list: y IP’s public of each link


· PC test configuration is IP with gw (Floating IP of the internal VLAN) its attached to a switch connected to 1.3 interface of F5 that is IP



Property SNAT Pool of VS_Outbound is set to None.



for now, there is in operation a SNAT with similar configuration with the only difference that the "PC test" is a firewall- in the external VLAN



but with this new configuration I can't reach any site in internet. What more should I need to do?



Thanks in advance.


4 Replies

  • Hi JB,



    a couple of things:



    1) set the SNAT to automap - once we get it working you can then use your own SNAT addresses (which will usually be IP's on the external VLAN, not of another device!)


    2) Set the VLAN traffic to the internal VLAN ONLY


    3) If you must use a virtual server for the outbound traffic it'll be a wildcard VS (*) to allow all traffic out. The pool will be the gateway(s) of the BigIP. You also need to turn off address and port translation of the VS in this configuration (to send traffic THROUGH rather than TO the gateway).



    Hope this helps!



    If you're still stuck, take a tcpdump!



  • Chris,



    Thanks for your reply...



    I just tried with your suggestions, but with the same result. With my workstation I can ping any IP on internet, but cannot resolve any name. For example, can ping and tracert but not or anything else.



    My workstation config is:






    GW (VIP of F5)


    DNS (VIP of F5)



    What more should I check out?



  • OK... all its fine now... it was a missed configuration.



    The price of the newbies.



  • Glad you got it working :)



    If you get anymore problems, we're happy to help!



    Enjoy your LTM, hope you like them as much as I do!