cancel
Showing results for 
Search instead for 
Did you mean: 

Traffic Policy vs iRule Pool Redirect

sgnormo
Altocumulus
Altocumulus

I am using a traffic policy to perform pool redirect.  I create the policy and attach to the virtual server.  In the virtual server I set the default pool to none.  I notice on the virtual server page that the icon next to the virtual server turns blue.

when i apply an iRule for a pool redirect and set the default pool to none on the virtual server the icon next to the virtual server turns green.

Is there a way to have the icon turn green next to the virtual server when just using traffic policies on a virtual server

2 ACCEPTED SOLUTIONS

neeeewbie
MVP
MVP

Hi 

you need default pool setting 

pool LB does not proceed when you set correct policy 

 

thank you

View solution in original post

I was hoping there was a way so as not to have to set a pool in the virtual server configuration, like i can when using an iRule.  Looks to be limitation with F5 traffic policy.

View solution in original post

3 REPLIES 3

gefra
Nimbostratus
Nimbostratus

Hi Sgnormo,

Do you have in your traffic policy also a rule for forwarding the traffic to a default pool in case other rules are not matched. Then you can still use this default pool also on your virtual server > resources > default pool setting. But it's some 'false' status information about the pools you are using in traffic policy.

Regards,
GEF.

neeeewbie
MVP
MVP

Hi 

you need default pool setting 

pool LB does not proceed when you set correct policy 

 

thank you

I was hoping there was a way so as not to have to set a pool in the virtual server configuration, like i can when using an iRule.  Looks to be limitation with F5 traffic policy.