cancel
Showing results for 
Search instead for 
Did you mean: 

SMTP VS is resetting the after 3 way handshake

Abu_Bakar_Afzal
Altostratus
Altostratus

We are facinig TCP reset from F5 VIP towards client after completing 3 way handshake. Can anyone support on this?

5 REPLIES 5

Hi @Abu_Bakar_Afzal,

I have a few suggestions to try to check:

  • Which type of VS are you using? ie: Standard vs FastL4.
  • Verify which tcp profile is in use, and consider swapping it to a "lan" or "wan" variant.
  • Is any SMTP profile in use?
  • Is the connection between the BIG-IP and the SMTP server busy, high latency, or otherwise congested?

Hi,

VS is Standard and we are using default SMTP profile. Connection is not even used its new deployement.

Nath
Cirrostratus
Cirrostratus

I think much better if you post your config of your VS here. Also, you can expand the RST, ACK as it might give you more details on why it is sending RST flags.

PFA RST flag output.

Below is the VS all properties output

ltm virtual SMTP_VIP_IPCORE {
address-status yes
app-cloud-security-services none
app-service none
auth none
auto-lasthop default
bwc-policy none
clone-pools none
cmp-enabled yes
connection-limit 0
creation-time 2022-03-01:13:11:05
description none
destination 10.13.61.45:smtp
enabled
ephemeral-auth-access-config none
eviction-protected disabled
fallback-persistence none
flow-eviction-policy none
gtm-score 0
ip-protocol tcp
last-hop-pool none
last-modified-time 2022-03-31:15:41:40
mask 255.255.255.255
metadata none
mirror disabled
mobile-app-tunnel disabled
nat64 disabled
parent-name none
partition Common
per-flow-request-access-policy none
persist none
policies none
pool IPCORE_SMTP_POOL
profiles {
tcp {
context all
}
}
rate-class none
rate-limit disabled
rate-limit-dst-mask 0
rate-limit-mode object
rate-limit-src-mask 0
related-rules none
rules none
security-log-profiles none
serverssl-use-sni disabled
service-down-immediate-action none
service-policy none
source 0.0.0.0/0
source-address-translation {
pool none
type automap
}
source-port preserve
syn-cookie-status not-activated
traffic-classes none
traffic-matching-criteria none
translate-address enabled
translate-port disabled
transparent-nexthop none
urldb-feed-policy none
vlans none
vlans-disabled
vs-index 486
}

william_7
Nimbostratus
Nimbostratus

I have the same issue.
Were you able to find the solution?