cancel
Showing results for 
Search instead for 
Did you mean: 
Login & Join the DevCentral Connects Group to watch the Recorded LiveStream (May 12) on Basic iControl Security - show notes included.

Persistence Not Working

genseek_32178
Nimbostratus
Nimbostratus
Hi,

 

 

For the following VIP, persistence is not working..

 

 

virtual syz-443

 

pool syzpl-443

 

destination 20.20.12.25:https

 

ip protocol tcp

 

vlans 25 enable

 

profiles tcp-profile

 

persist persist-source-addr-syz

 

 

 

http://20.20.12.25/lb/on.txt is giving different server every minute when persistence is set to 600 sec.

 

 

any help here would be great on what is causing this?

 

 

genseek

 

5 REPLIES 5

MVA
Nimbostratus
Nimbostratus
Just taking a quick look at your posted config, it seems as though your destination is https but the URL you posted is http. Is there another Virtual Server using http without persistence?

genseek_32178
Nimbostratus
Nimbostratus
yes there is another VS that is using http with persistence.

genseek_32178
Nimbostratus
Nimbostratus
i noticed the following also..

 

 

persist-source-addr-syz - IS the custom profile...AND

 

 

persist-default-syz - Is the default profile

 

 

Although, the persist-source-addr-syz is set for timeout vlaue of 600,

 

 

the persist-default-syz profile seems to be having no setting of timeout value

 

 

b profile persist-default-syz list

 

profile persist-default-syz

 

defaults from sourceaddr

 

 

As no timeout setting is defined the custom profil persist-source-addr-syz , must be inheriting timeout settings from the parent profile.

 

and therefore persistence is not sticking till 600 secs.

 

 

Could this be the reason?

genseek_32178
Nimbostratus
Nimbostratus
nitass, any updates?

genseek_32178
Nimbostratus
Nimbostratus
the working VIP1 is runing on 10.2 and non-working VIP2 is running on 9.4