cancel
Showing results for 
Search instead for 
Did you mean: 

iRule in system log

ywa
Nimbostratus
Nimbostratus

Hello,

 

I installed a new BIG-IP VE 15.1.3 appliance and I see some strange behaviour in the logs.

 

In the system log, I have the following line that constantly appears at an interval of 20 mins :

 

... Mon Jul 26 03:40:01 CEST 2021 bigip.example.com syslog-ng ) Mon Jul 26 04:00:01 CEST 2021 bigip.example.com syslog-ng ) Mon Jul 26 04:20:01 CEST 2021 bigip.example.com syslog-ng ) Mon Jul 26 04:40:01 CEST 2021 bigip.example.com syslog-ng ) Mon Jul 26 05:00:01 CEST 2021 bigip.example.com syslog-ng ) Mon Jul 26 05:20:01 CEST 2021 bigip.example.com syslog-ng ) ...

 

And when I update an iRule, the code of the iRule appear in the System log too.

 

For example, if I create a new iRule with this content :

 

when HTTP_REQUEST {   if { ! ( [HTTP::header exists "X-Forwarded-Proto" ] ) } {   HTTP::header insert "X-Forwarded-Proto" "https"  } }

 

Then I have the following that appear in the system log : 

 

... Mon Jul 26 11:23:20 CEST 2021 bigip.example.com syslog-ng }" } } [Status=Command OK] Mon Jul 26 11:23:20 CEST 2021 bigip.example.com syslog-ng } Mon Jul 26 11:23:20 CEST 2021 bigip.example.com HTTP :header insert \"X-Forwarded-Proto\" \"https\" Mon Jul 26 11:23:20 CEST 2021 bigip.example.com if { ! ( [HTTP :header exists \"X-Forwarded-Proto\" ] ) } { ...

 

Does someone have an idea why this is happening and if it is possible to avoid this ?

0 REPLIES 0