cancel
Showing results for 
Search instead for 
Did you mean: 

GTM Continues to Resolve (Generic Host) IP's From Pools That Are Down

luevelvet
Nimbostratus
Nimbostratus

Hello All!

 

I have a strange situation and I'm sure we're simply missing something simple here.

 

The initial goal:

Configure a WIP for a smtp FQDN with a PROD and DR pool behind it where GTM will resolve only to IP's in the PROD pool until all PROD pool IP's are down, after which is will resolve IP's in the DR pool.

 

The issue:

We have a simple WIP with two pools (PROD and DR) behind it set to Global Availability load balancing method. During our testing, we simply disable the services on the PROD pool which triggers the monitor to mark the servers/pool as down. The problem is, even if the GTM marks the pool as down, it will still resolve IP's in the PROD pool. It does resolve to IP's in the DR pool as well, but it flaps back and forth between IP's in both the PROD and DR pools.

 

I'd be happy to provide more info, but this is truly as basic of a config as I can think of. One WIP, two pools of generic hosts yet when one pool goes down, the GTM still answers to IP's in the down pool.

 

Any suggestions are welcome as this is holding us up on putting this into production prior to BCP/DR testing scheduled before the end of the year. 🙂

2 REPLIES 2

cjunior
Nacreous
Nacreous

Hi, 

I understand you have defined the "Global Availability" method in WideIP level, 

so I understand that PROD pool is trying to do a "Fallback" once it has no members available.

This fallback option is usually defined as "Return to DNS" by default.

Try to change this to "None" in this PROD pool and let us know if it works as expected.

Kind Regards.

 

luevelvet
Nimbostratus
Nimbostratus

Hello!

 

We were doing a bit more troubleshooting yesterday and found exactly what you suggested fixes the issue. We noticed the pool statistics for the WIP was showing a number of attempts at Return to DNS and Fallback and we changed these to None on the pool level and now it's behaving as expected!

 

Thank you for the reply. 🙂