cancel
Showing results for 
Search instead for 
Did you mean: 

enable WebSocket profile.

mdtariqul
Altostratus
Altostratus

We want to enable WebSocket profile. I set is "websocket" in the virtual server

To enable it, HTTP profile needs to be enabled. I set it "http" in the same virtual server

We have SSL communication through F5 LTM from the internet, if I enable HTTP profile -- the connection is not established with the server. 

Anything I need to configure? 

Thanks in advance. 

1 ACCEPTED SOLUTION

if you do not offload (or bridge - decrypt / re encrypt) SSL on the BIG-IP you can't do other profiles as the BIG-IP can only the encrypted traffic, which it can't read / understand.

View solution in original post

5 REPLIES 5

PSFletchTheTek
Cirrocumulus
Cirrocumulus

Hi,

So websockets is part of the html payload.

So you need to be able to see that payload for the profile to take affect.
Have you got the client ssl and server ssl configuations on?

Before you enabled the websockets profile, was this a working setup?

We did not off-load ssl in our LTM (Local Traffic Manager, i4800; BIG-IP 16.1.0 Build 0.0.19 Final). We only create sessions for 443 https virtual servers, ssl is maintained by internal servers. So, this was a working setup.

Now the application vendor needs the WebSocket session.  I just enable it in the virtual server as follows, and then the total communication stops. 

mdtariqul_3-1654682729847.png

to do this, we need to enable http profile

mdtariqul_2-1654681914845.png

it seems I am not on the right track. 

if you do not offload (or bridge - decrypt / re encrypt) SSL on the BIG-IP you can't do other profiles as the BIG-IP can only the encrypted traffic, which it can't read / understand.

Finally, we are going for off-loading. 

Thank you all for the support. 

@mdtariqul - If your post was solved it would be helpful to the community if you selected Accept As Solution on the relevant reply (or replies). This helps future readers find answers more quickly and confirms the efforts of those who helped.

Thanks for being part of our community.
Lief

------
Lief ZimmermanLiefZimmerman | @LiefZF5 | DevCentral Community Manager