cancel
Showing results for 
Search instead for 
Did you mean: 

Configuration of the custom parameters of the RDP application in APM

Alex_Tsang
Nimbostratus
Nimbostratus

Hi all

 

I configured a RDP application by using native client type in the APM and I would like to put some RDP configuration (such as below) in the customer parameters. But after I add it, I found that those configuration are not in the rdp file generated by F5 APM. So may I know if you have same experience? If yes, how to solve it? My BIG-IP version is 13.1.3 Build 0.0.6

 

Disable wallpaper:i:1

Bitmapcachepersistenable:i:1

 

Best regards

 

Alex Tsang

4 REPLIES 4

Smithy
Cirrostratus
Cirrostratus

You add the settings to the “Custom Parameters” field, one per line. Great overview of these Parameters here: https://www.donkz.nl/overview-rdp-file-settings/.

 

I just added “redirectclipboard:i:0” to my RDP config and it stopped copy/paste when I tested it.

 

0691T000008G64DQAS.png

 

BIG-IP: 14.1.2.1

Hi Brett

 

Thanks, and I did the same but not working in my environment. These configurations should be appear in the RDP file generated by F5, right? If yes, I cannot find the setting configured in the custom parameters appear in the RDP file.

 

Best regards

 

Alex Tsang

Smithy
Cirrostratus
Cirrostratus

Hi Alex,

 

Yes, they should be in the RDP file. I removed "use multimon:i:1" and "span monitors:i:1" for this test from the above configuration.

 

This is the RDP file from my test with only "redirectclipboard:i:0" included in the "Customer Parameters":

 

authentication level:i:0

enablecredsspsupport:i:0

full address:s:rdsh1.f5.demo

gatewayaccesstoken:s:uLOn/y2GmR7_fHAEtXsw9w

gatewaycredentialssource:i:5

gatewayhostname:s:rdp.f5.demo

gatewayprofileusagemethod:i:1

gatewayusagemethod:i:1

redirectclipboard:i:0

server port:i:3389

 

Cheers,

 

Brett

Hi Brett

 

We finally find that the custom parameters will apply after we reboot the system, so I believe this may be bug in my release and we opened case in F5.

 

Best regards

 

Alex Tsang