Forum Discussion

tshilidzi_66258's avatar
tshilidzi_66258
Icon for Nimbostratus rankNimbostratus
Sep 23, 2009

WCCP on Cisco 3750 Switch with Wanjet 500

I am experiencing a problem with a WCCP config between a Wanjet 500 and a cisco 3750 switch. There is a wanjet 300 on a remote site. There is full connectivity between the WJ. When everything is configured I am able to optimize traffic in only one direction. I have a server farm hanging off a VLAN on the 3750. The remote Wan Jet is inline on the site but i want to configure WCCP to work between my 3750 switch and the WJ. The WJ config is correct but the 3750 config is a little bit troublesome.How can i get the Traffic to be optimized in both direction?

 

Here is my config on the switch

 

VLAN 11:Server VLAn

 

Vlan 17:Wanjet vlan

 

Wan Jet IP address: 192.168.230.10 255.255.255.0

 

ip wccp 99 group-list 15

 

!

 

!

 

int vlan 11

 

ip address 192.168.220.1 255.255.255.0

 

ip wccp 99 redirect in

 

!

 

access-list 15 permit 192.168.230.10

 

!
  • macwilliams_566's avatar
    macwilliams_566
    Historic F5 Account
    The Cisco 3750 switch needs to have SDM configured in order to redirect packets to the WANjet. Also, the 3750's only support L2 and assignement = mask. See below for a working configuration.

     

     

    Here is a sample Cisco config:

     

    !

     

    sdm prefer routing << you need to save and reboot the router after this.

     

    [...] << also notice that it does not show on the output of 'sh run'

     

    ip routing

     

    ip wccp 51

     

    !

     

    [...]

     

    !

     

    interface GigabitEthernet5/0/2

     

    switchport access vlan 5

     

    switchport mode access

     

    !

     

    [...]

     

    !

     

    interface Vlan1

     

    ip address 172.30.13.247 255.255.255.0

     

    !

     

    interface Vlan5

     

    ip address 10.102.0.254 255.255.255.0

     

    ip wccp 51 redirect in

     

    !

     

    !

     

    interface Vlan10

     

    ip address 10.102.1.2 255.255.255.0

     

    !

     

     

    And the WANjet 500 config:

     

     

    b wccp list all

     

    wccp server-wccp {

     

    cache timeout 10

     

    services 51 {

     

    priority 10

     

    protocol tcp

     

    port type none

     

    traffic assign mask

     

    hash fields srcip

     

    weight 50

     

    redirection l2

     

    return l2

     

    tunnel local addr 10.102.1.201

     

    password none

     

    egress method negotiated

     

    routers 10.102.1.2

     

    port none

     

    tunnel remote addr 172.30.13.247

     

    }

     

    }