Forum Discussion

Nicol4s's avatar
Icon for Nimbostratus rankNimbostratus
Sep 02, 2021

sshd could not load host key



I'm running a fresh install of BIG IP VE using TMOS


The sshd daemon is not able to start because of the following message :


Could not load host key: /config/ssh/ssh_host_rsa_key


When connected using the bash terminal, I can see the content of the key just fine.


I have tried to relabel the filesystem in order to fix the SeLINUX permissions but still no dice.


Procedure that was applied :


thank you.

2 Replies

  • Hello Nicol4s.

    You just need to recreate your SSH RSA key.

    ssh-keygen -t rsa -f /config/ssh/ssh_host_rsa_key
    systemctl restart sshd

    Let me know if it works in your case.



  • Hello Dario,

    I did something very similar to your solution :

    KB Reference used :

    bigstart stop sshd
    restorecon -rF /config/ssh/ssh_host_*
    bigstart restart sshd
    journalctl -u sshd

    Now the SSH daemon is able to start correctly when my VM boot or reboot.

    Thank you for the tip.