Forum Discussion

gregori_33925's avatar
gregori_33925
Icon for Nimbostratus rankNimbostratus
Apr 04, 2012

RANCID and cli pref pager disable

Been converting RANCID to tmsh, however my default read-only rancid user defaults to tmsh, and so is unable to get a non-paged config via 'tmsh -q list'

 

 

So, I simply adjusted that user's cli preferences to disable the pager. 'modify cli preferences pager disabled'. Easy, done, hurrah.

 

 

 

However, some of my units running v11 and later dont believe cli preferences should be available to a remote/read-only user, and when I try to set this, I get this:

 

 

 

01071507:3: User, foo, doesn't exist for for cli preference.

 

 

 

Where "foo" is the name of my read-only user.

 

 

 

Any ideas? I would like to avoid reverting to bash if possible...thanks

 

 

 

1 Reply

  • I have the same error (and problem)...also been trying to get RANCID working with the tmsh prompt. My units are all on v11 and don't accept the command either. I thought the clogin script took care of paging but perhaps the prompt difference is causing that to fail.

     

     

    I commented on a post where someone else had tried to get RANCID working with tmsh (https://devcentral.f5.com/Community/GroupDetails/tabid/1082223/asg/44/aft/2158962/showtab/groupforums/Default.aspx) - perhaps it'll help.

     

     

    If you get your script working, I'd sure appreciate a copy! Will post back if I get something too.